Select Item 'SELECT [id]': Error HRESULT E_FAIL has been returned from a call to a COM component

Hi, I’m facing this error which I had tried few suggestions from previous topics. However, it turned out not the solutions for me. I had tried to uninstall and install .Net Framework (wondering is it the dependencies in the UiPath packages, or from local PC itself), ran UiPath Studio as Administrator, changing the selector, test on another machine, and also changed it to Click activities. The Click activity is not success due to not supported as shown in the screenshot below:
image

Error:

UI from web browser IE 11 (red circle indicate the value I need to select):
image
image

Is anyone have any idea about this error?

@Colleen_Cheam Have you tried using Type Into Activity?

@supermanPunch hi, unfortunately Type Into activity cannot be use. I observed the html code is parsing some JavaScript function to backend for the selected value.

My guess is that your are not waiting for the control to be fully loaded… Do you have the error when you are getting the selector using uiexplorer (after waiting it to load)?

Hi @bcorrea, I didn’t get error when I getting the selector using uiexplorer. It is validated and highlighted as shown.
image

Thanks all for the prompt reply! After few hours of digging, it seems to be the backend JavaScript (OnChange function) is the root causes for this. And I don’t wish to use Inject JS Script activity as it might be tedious in maintenance after the project signed off.

I found a workaround according to this post here:

  1. Using Click activity to expand the drop down list
  2. send hot key : because my options are string format, so I can only use “down” key
  3. send hot key:enter

Thanks again!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.