Autofill for web sites?

I have a workflow that uses type into and Select item activities to Complete a web form. Upon completion, some fields are supposed to be filled With numbers and text as well (based on what has been selected from one of the drop down menus). I’ve tried a lot of activities to activate these fields, but so far to no avail.
Any suggestions?


Are you asking about how can you choose the values from the drop down menu suggestions after typing them?

No. Some fields are supposed to be completed after a drop Down menu Choice. This happens when done manually, but not when the robot does it.

sorry I don’t quite get the problem, do you have an issue with selecting items (that contains numbers and text ) in a drop down menu ?

No. That I can do just fine. The problem is when a drop down choice has been made and some other Fields on the web page are supposed to be completed automatically based on the value selected in the drop Down menu.
This happens when I do it manually, but not when the robot does it.

is the Bot selecting the correct item in the drop down? if yes, the site should load the other fields automatically…

can you please share the workflow / screen shot and the selector. what website you are accessing.

Maybe try adding a key for ‘tab’ so after selecting the field from the dropdown the robot will hit the ‘tab’ key, this is in case the control is still waiting on that dropdown. Just suggesting a workaround, do look for some other options as suggested by the community as well and try sharing your project as well.

I cannot share either a screenshot or the workflow.
Imagine this: Ona web page I use a Select item Activity to Select from a drop Down menu. The robot Selects the right element, and it stays selected. All is well so far.
However, when doing this manually, six other Fields on the web page get date and time values automatically based upon which element was selected in the drop Down menu. This does not happen when the robot performs the exact same action.
And yes, I’ve tried I lot of Things to remedy this, also hotkeys, clicks, double clicks, etc.
I believe I’ve used every tool in the UiPath toolbox, and have now started scripting in hopes this will fix the issue. Not sure after drop down give some delay and check

I’ve tried that. All the delay options, all the click options, hotkeys, monitor events, etc.