Website not selecting appropriate dates

Hey Guys
iam automating a web page in my project
when iam manually entering dates and clicking its taking correctly

But when iam automating with uipath type into its not taking correctl

please guide me

Hello @Shoebmd

You can refer to the below video.

1 Like

its good video but bro when iam entering date and clicking on apply manually its taking


when iam entering through bot its not taking correctly


Is it possible to type the data in to that field ?

If yes just take one type into and pass the date


Assign activity and assign the date to one variable

Choose the aaname from the selector replace the aaname with variable like this

aaname = {{Variable}}

This will click on that date…

And make sure you checked the following options in click or Typeinto activities

  1. Activate
  2. Wait for ready - Complete
  3. Click Before type
  4. Delay before - 200
  5. Delay after - 200


please check the format of the date that you are entering. I think the format of the date which you are entering using the bot is not acceptable.

Hey everyone

i tried all above methods which u guys suggested but stil not able to get results

dates format is correct when iam clicking apply in manual its taking but with bot not taking


Have you tried the above mentioned steps?


Hello @Shoebmd Please check whether the bot able to click on Apply button. To confirm this, validate and highlight the selector of click activity

Yes bro

I think this google search console website is having some issues

Please guide me if u have any solution

Iam very tense

Hey Guys

when iam trying hardcoded values in type into activity its working but when giving

Today.AddMonths(-2).ToString("yyyy-MM-dd ")
the above formats its typing correctly but not reflecting results


What do you mean by not reflecting?

Could you please send us the snap


Hi @Shoebmd ,

Today.AddMonths(-2).ToString("yyyy-MM-dd ") - Is this the exact code you are using in Type into?

If yes, Then there is an extra space in the date format, please remove and check whether it is working or not.
Today.AddMonths(-2).ToString(“yyyy-MM-dd”) - Try this


i can type in that place with this logic correctly but when clicking on apply its not taking that instead taking some old values


Type manually and check… Whether it is selecting the date or not…

Instead of clicking on Apply try to do enter or tab something like that


After typing date, before clicking Apply use click activity and click some other random element in application and then click Apply.

tried this but no use