Version mismatch error

i am getting this error “The installed versions of Studio and Robot do not match. Please restart your machine and try again.” whenever ui path automatically updates to a new version.
before 7 days the same problem occurs at that time i uninstall ui path and reinstall it. then the problem solved. now today also the same error came. what can i do to overcome this error?
i am using community edition stable version.

@lakshman,@lahiru.fernando,@loginerror Please check this.

Hi @arijit1213

Can you check the two versions in Studio and in the Robot (Assistant) window? In the Assitant, if you go to settings, you can see the version of the robot, and in Studio, go to Help, and you will see it there, or you can see it on the bottom left…

Can you check whether those two have the same version?

1 Like

hi @Lahiru.Fernando
checked. studio has updated but ui path assistant not updated.
This problem occurs whenever studio got auto updated.

1 Like

hmm… That’s weird… ideally both should get updated at the same time…
Are you using the stable version or the beta version of Studio?

1 Like

HI @Lahiru.Fernando
what can i do to overcome this error ?

Hi @Lahiru.Fernando
i am using stable version.


Try uninstalling, and installing again, but this time, stick with the beta version and see whether that makes the difference… :thinking:

And when it occurs after that chrome extension not working.

i did not get any solution how to fix this error.
@loginerror, @lakshman please help me.

ui path studio auto updated but ui robot does not updated.

Have you tried restarting your machine when it happens?

restarting normally solve this problem. This problem mainly occur when you open “Assistant” first and then Studio.

After restart, If you open Studio first, this problem won’t occur.

@loginerror @Robott
yes. i tried to restart the machine after that also the same error throws.

After restart, did you open the Studio first?

1 Like

hi @Robott
yes. i opened studio first.