ERROR: robot do not match with installed version

Hello,

Today I downloaded the Community Edition again and now I can’t open my recent Projects.
I always get the ERROR
“The installed versions of Studio and Robot do not match. Please restart your machine and try again.”
And the restart doesn’t help anything.

2 Likes

hope this thread would help you on this

CHeers @Loons

1 Like

But where do I find this checkbox?

Okay, I found the checkbox. But I saw that I already ticked the stable version…So this couldn’t be the problem.

fine kindly restart your machine and try once
Cheers @Loons

Did it several times. But it still doesn’t work…

Hi Loons,
Click “Open Logs” in the error message to open UiPath Application Folder.
Then, run new version of UiPath, below .exe file:
C:\Users[YourWindowsAccount]\AppData\Local\UiPath\UiPath.Studio.exe

Stop UiPath Robot Service
Start UiPath Studio
Start UiPath Robot Service
Better then a Reeboot
Tested on Verion 2019.11.0.Beta2

3 Likes

Followed as suggested by this post

  1. Go to Windows services: Win + R
  2. Type “services.msc”
  3. Find “UiPath Robot” and restart

Hi! the above steps are done! yet facing the same issue! I currently have 2019.10.2 version. Any solution pls?

1 Like

Hi @PavithraSundaram if you can open your recently installed community. Create a new project and import your workflow into the newly created project

cheers :smiley:

Happy learning :smiley:

1 Like

Thanks @Pattryricate! But im still not able to open the UIpath studio! I tried opening recently worked file from file explorer. still the same error msg pops up!

1 Like

Can you unistall the community edition and try to install again.Thanks @PavithraSundaram

cheers :smiley:

Happy learning :smiley:

2 Likes

Hi, did you solve the issue with @pattyricarte help? Sometimes I had solved related errors by deleting “settings.json” file (in your project’s folder) in order to force UIPath to re-generate the proper workaround.

I also suggest you, in the 3rd step I wrote, to STOP the service, reboot and START it again.

Regards

1 Like

Hi @pattyricarte, I reinstalled the community edition and works fine now. I had 10.1 version and that had no issue. the 2019.10.2 has this issue.

thanks for extending your help! :slight_smile: Much appreciated!

Go to path (C:\Users[YourWindowsAccount]\AppData\Local\UiPath) and click the older version, it’s works to me :slight_smile:

Go to Task Manager and Kill UiPath.Service.UserHost, to resolve this issue with out restart

1 Like

you get this error when you have installed two different version of an Ui Path studio.

This happen to me after I uninstall the beta version this problem got solved.

1 Like

its working, go to task manager, kill two tasks regarding ui robot. that’t it.

Be Happy
Narasimha

1 Like

Selvakumar, THANK YOU your solution worked for me. I had the same issue so I went to Task Manager and saw 2 instances of UiPath running so I killed one of them and it worked. Thanks again!