Unable to use mouse hover activity for hover on the 1st element from a list

unable to use mouse hover activity for hover on the 1st element from a list.

  • I have used parent selector in “find children” activity and then used for each loop for traversing on each element.
  • on each child need to use hover activity.

below is my attached screenshot for the same.

What data you want after hover on the elements?

after hovering on an element, popup will be displayed. so from that popup need to fetch details by using find children activity.

In that you should look for a smarter solution, use UiExplorer and see what selector you can create for that popup, find that parent of that and use Find Children activity once you find children if that has value in an attribute you can use Get Attribute activity to get the value

Thanks,
Prankur

1 Like

Yes, that is next process which I need to perform, However I am stuck at first point where I need to hover on 1st element and then popup will be displayed to perform operation which you mentioned. :frowning:

Even if you dnt hover the popups exists in the page structure, you can definitely pick them using UiExplorer without hover

Hi @prajakta3

You can try this-

  1. Use click activity to drop the list down.

  2. Press F2 on your keyboard, this will give you a 3 second delay before picking your element. Click on the drop down list then wait for the indicator to appear again to select the required element. This will set the selector for the element.

Actually, problem is that, its not the part of hover on single element and get details out of it… There is list on companies and from each company popup need to get details. so in that case,how it would be possible to take parent of each popup of for each company.

Completely agree. But if it is there on hover this means that it is there in the HTML DOM structure. Try to find it through UiExplorer or you can also try pressing f12 while webpage is opened.

Or if its not confidential do let me know the URL will find out

Thanks,
Prankur

Hey Thanks However it is confidential … Can you please share your skype details, probably I will communicate through that channel as it is imp and not working from my side.

Today, again I have tried now it is working fine … Thanks alot… :slight_smile:

1 Like

Hi Prankur,
I am facing the similar issue. Hovering on an element > list will open > again there is 2nd hover element and then need to click on 3rd element. I have tried with UIexplorer and i can see the 2nd element. I select the element which is in the UIExplorer but no luck.

I am Getting “RemoteException wrapping UiPath.Core.SelectorNotFoundException”

Please help !!

You can try indicate on screen hover to that element and press F2 once list is open select the required element.

If you are still facing the issue share a screenshot or code.

Prankur

Thank You Prankur, that issue got resolved by using UIExplorer and pressing F12 didn’t work for me. Now I am trying to click on 3rd element. If I get some issue in that then i will get back to you.
Thanks !!