Unable to type secure hash code into comments field for Assignment 1

Hi,

I am unable to type into the hash code generated in comments field. I previously use a write line activity to see if hash code is retrieved and it is getting retrieved fine.
I also tried using Navigate to activity with this link : “https://acme-test.uipath.com/work-items/”+in_WID. But getting inauthorized error in ACME application.

Please help in resolving this.

Hi @Santa_Krish

Welcome to uipath community
Fine while using type into activity to type the hash code enable these properties in type into activity,
–Simulate type
–Clickbeforetyping
–Emptyfield

This would make sure that the element is identified and text been typed
and kindly follow these steps to get into the web portal and type this text in the comments field

–use a attach window or attach browser activity and highlight this window where you are trying to type the comment and enter the other fields
–then use the type into activity and other click activities inside this attach window or attach browser activity…that would enter that the typing is done in the active window…
Kindly try this and let know buddy for queries or clarification
Cheers @Santa_Krish

Hi,

I tried as you asked to - enabled Simulate type, Clickbeforetyping, Emptyfield. But still unable to send the hash key in. I tried with a normal string input and it is entered into comments field perfectly.
Only the add comment step gets skipped and the subsequent steps are executed.

1 Like

Fine
make sure all these activities are inside a attach browser activty or a attach window activity
and make a click on the field where you want to type with a click activity and place the type into activity next to the click activity and try to enter the hask key in it buddy
Cheers @Santa_Krish

1 Like

I tried the same sir, but still no result:-(

@Santa_Krish,

You also use Type Into activity with Simulate Type property enabled without using of Click activity. Also enable click before type property enabled.

Let me know if it’s not working.

TanQ,
Michael Udhaya

@Michael_Udhaya I tried as you said but its getting stuck at comments field. PFA the workflowUpdateWorkItem.xaml (18.8 KB)

Sorry @Santa_Krish, I’m not using system now. Can you please check the comments box selector once. Because when you Navigate to another page, the page title was changed. So change the title attribute with the *. If you use the Attach Browser you can also need to change the title attribute.

1 Like

My opinion is that there is no issue with selector since i am able to navigate to the window needed. Even the comments field is getting identified and the cursor is placed inside during that appropriate step. Dunno why hash isn’t getting inserted

Okay then try Set Text activity instead of Type Into

@Michael_Udhaya Following is the error message that I am getting when I used Set Text instead of Type into. Any other suggestion?

@Santa_Krish,

Can you show the Selector of the comment box that you used in the code and original selector of the box?

Original selector:

Selector I am using:

Hey @Santa_Krish, you just try the original selector instead of your own selector. I think it will be fine with enough attributes. Include Name attribute as well.

If it not working, use type attribute instead of tag attribute with the rest of attributes.

Note : before proceeding with Selectors, check with Indicate Element in the UiExplorer.

I am having this problem as well. It goes through and marks it complete but I think my problem is the hash value is not being passed. Any ideas?

@Rahim_Pradhan

Check the arguments whether you passed properly or not ?

What Activity are you used to read hash data from browser ? After reading try to print the value to check whether it is reading properly or not.

1 Like

I think my issue is with the arguments. I did a write line and it is grabbing the value.

1 Like

@Rahim_Pradhan

Ok pass it properly and then try again. It will work.

1 Like

How do I pass it properly?