The hash code is not written in the comment section

Hi all,

My code is good, I have my HashCode create for each client, bu when the window with comment section is open, the hash code is not written and no complete. Can you help me to resolve this problem please.

You can try to open that popup in the same window instead. Use navigate to and give the url for updating WID item


Did you check if In_comment and Out_HasCode are linked

I.e. after you get the out_HasCode value you are assigning it to in_Comment while invoking your comment workflow?

1 Like

Thanks @PrankurJoshi, I try to open in the same window unsuccessfully.

Thanks @neonova , I assign value correctly as you can see:

as @PrankurJoshi suggested @MigT open the pop window and see the url

directly open that URL once you have the hashID instead of opening a pop up window (it works try it!)

Then try adding the comment. The main reason the comment isnt being written is because the robot is unable to find it on screen or the in_comment value isn’t there (log/write it to confirm the value is coming till there)

If it is then the case is simply that the robot is having an issue with selector, so experiment around (can try using anchor base activity for more accuracy)

Thanks @neonova try it but the result remains the same. I think the problem is the selector because in the window I have not the comment section as you can see below:

And here you are my code of update WI hashcode:
System1_Update_WorkItem_HashCode.xaml (19.6 KB)

And I’m sure that my code is uploaded because with my write line the code is presented.


You ar eusing two different browser. One step above you are attaching somewhere else and in next step you are opening a new browser in a different sequence!

After attach use navigate to activity

Current URL : “ACME System 1 - Log In*”

try with >>ACME System 1 - Log In (change the workID number for your specific WID at runtime)

and selector for type into activity should be:

try first putting eveyrthing in a single browser container. if that still fails try changing the selector

Thanks @neonova but I triy it but i have this message

@MigT that error comes if your link is incorrect . Check the link please for your work item

The link I gave above is for my work item specifically , it’s an example . You have to get your own

Simply manually go to work item >select a w15 work item > click on update copy the link in the pop up window .

Use that link . Just change the WID at the end of the link to navigate to the other work items directly

I tried it and I try it again but unsuccessfully. so I did this :

And it’s also process with success but I don’t see written the hash code in comment. And when I submit on the plateform and I have 7/100. I don’t understand

@MigT could you please record a video for one case (process of one work item end to end )

Also I hope you are using only one browser container now instead of two like before

Tell me your first W15 work ID I’ll make the link

Here you are the video @neonova.

Yes i’m using one browser container as you can see on the record.

I show you just for 2 client but you can see to the begining of the video that when I run all the process, all is with successfull according to the output window.

Video of process assignement 1 (2.0 MB)


In your last invoke workflow (update hashid)

in attach browser and put a navigate to activity
with URL as>> “ACME System 1 - Log In”+WorkID_Variable

where WorkID_Variable has value of your Work ID (eg 505255,823125 etc)

try this link for the update part of transaction 11 and 12 >>

Tell me what happens


Please refer to these Screenshots to understand about the urlStep1

Thanks a lot @neonova, it’s run perfectly but now the status is “completed” not “open” so if I run again that doesn’t work and I submitted and I have 7/100. Do you know why?


Reset your data as per instructions and see what happens

bonne chance mon ami :slight_smile:

Thanks @neonova :wink: but now I have 0/100, it’s inexplicable

Please check formula it should be ClientID-FirstName LastName-ClientCountry

Have you used Trim function?

Yes it’s ClientID-FirstName LastName-ClientCountry, but I don’t used Trim function

Just wanted to make sure because I can see so many white spaces in the video


Because spaces will force a wrong hashcode