Unable to migrate license from Trial to Community Edition

I want to migrate UiPath License from 60 days trial(which got expired) to Community Edition. But I am not able to install community version on my system. How can I release my device Id?

Also I tried downloading Community setup. But while Sign In, it is asking for interactive signin and I donot see any other licensing methods on selecting More options on screen.

Can someone help on this.

Hi @shalini.singh0509,
Welcome to the community. Were you using Stand-alone studio license for 60days? or was it enterprise connected trial license?


It was Stand alone studio license for 60days.

Ok. You can de-activate the expired license I believe. Also one more thing to note, if it was an Enterprise Studio you have installed before, it won’t work with community license. You will have to uninstall the enterprise studio, install the community studio and connect with community orchestrator.

I have tried uninstalling first and then installing. Later I can see Interactive sign in option after I run UiPathStudioSetup . If I click ‘More Options’ - It goes to ‘Choose a licensing method’ page, but it shows no options to select. So I am not able to go further.

Can you give it a try from UiPath Assistant instead directly going to Studio?

I cant see any option to open studio through Assistant. I can just see Orchestrator settings. Attaching the screenshot.

Also there is no ‘Sign In’ option.

@shalini.singh0509 - Can you confirm you have installed community studio with UiPathStudioSetup.exe file?

Yes correct, community studio with UiPathStudioSetup.exe file.
On my same laptop, I had earlier 60 days trial version UiPath which got expired.
So not sure, if that interfering with community version.

May be. The UiPathStudioSetup.exe won’t list the robot as a service so you won’t find it in Services. The robot service gets registered only for UiPathPlatformInstaller.exe and UiPath.Studio.msi when you prefer Service Mode during installation.

The UiPathStudioSetup.exe by default goes to User Mode and sign-in option will be available.

Can we do a cleanup?

  1. Uninstall every Studio/Platform Installer you have from Control Panel
  2. After uninstall, Delete the UiPath folders if it’s available in the following places (if you have given any other custom location check that as well),
    - C:\Program Files (x86)
    - C:\Users<user>\AppData\Local
  3. Download the latest Community edition from Cloud and install
    Let us know if it’s possible.

I have tried all these options. But nothing worked.