Unable to get credentials from orchestrator

Hi Guys

i am unable to get credentials from orchestrator with the get credentials activities that used to work before i now get a pop up asking for user to input in the credentials which not what should happen. my robot is connected to the orchestrator and i have verified the credentials that are the same on both sides. i have also done a research where they mentioned is some compatibility issues but i have tried to change the package versions with no success. Can anyone help as i am trying to complete assessment 2.

Kind Regards

Reuben Kekana


are you using the config file to store the asset name?, double check that the name matches

and also try running it in debug mode and put a break point in the get credentials activity and zoom in to the parameters, maybe that will help you get into the issue

Hi @SenzoD i was previously using a config file but now to just to test the process i had to manually put in the parameter values just to see if it indeed working but still it could not get the asset from orchestrator instead it jump to the windows credentials as if the orchestrator was not specified or was incrorrect. i can share xaml file if you want?

mh is it possible to share screenshots or the workflow to help me understand better

Hi @SenzoD please see the attached files. the workflow was working fine recently but i think there might have been some updates that may have affected this. i am currently using community studio 2020.10.5 beta version.

System1 Login.xaml (15.4 KB)


issue may be coming from here (see highlighted below), you would be able to know for sure if you run the entire project in debug mode and put a breakpoint in the GetAppCredentials activity

in_System1_Credential may be empty and passing nothing to in_Credentials thats why it moves to getting windows credentials.

Try this one, it should at least help you get to the bottom of this

Calculate-Client-Security-Hash-master.zip (2.3 MB)

and also make sure you are not using activities that are in preview:

uncheck the “include Prerelease option”

in_System1_Credentials should have a value according to the assignment below , please correct me if I’m wrong?

Thanks il try the solution as you mentioned and revert back.

1 Like

Hi @SenzoD I still get the same error under your workflow and I’ve also unselected the preview versions of the dependencies under packages. please see below along with the variable watch.

what is the asset name in Orchestrator?

make sure the asset name in orchestrator matches the asset name in the config file, just runn the project in debug mode and step into geAppCredentials, this will make it easier to identify the issue.

1 Like

I’ve actually went and copied the asset name (Acme_Credentials) in orchestrator to make sure its the same. when run in debug mode i set a breakpoint at “get credential” workflow and when i step into it i get the pop up window(“Hello im a robot”) and when i check the values in the parameters they are correct as stated in config file. at this stage im now clueless.

my last attempt to resolve this was playing with the packages under package manager by going into lower versions as suggested in others posts but that doesn’t seem to work as i tried several lower versions of the packages.


You can send me Google meet invite, so you can share your screen with me.

1 Like

Great you can let me know your availability? i assume you in SA right?

Yeah im in SA, anytime after 16:00

1 Like

Thanks we’ll meet then…

1 Like

Hi @Senzo thank you very much for taking time to assist, the resolution steps are below as follows:

  1. checked whether the robot was connected to the same work space as in the orchestrator.
  2. verified that the asset name in the config file matches the one in orchestrator under my namedWorkspace.
  3. lastly ensured that the studio is connected to the same namedWorkspace.

The robot was able to fetch credentials from Orchestrator.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.