Facing error while doing assessment Calculate Security Hash

Hi, Getappcrendential workflow prompts me for credentials rather than getting it from orchestrator when I run it. This happens also when I invoke it in the System1 login process workflow created for Level 3 assignment 1. I have set the Argument In for CredentialName for the invoke workflow.

Does Get credential always throw input box for username and password?

HI @Leela_Javvaji

GetAppCredential work in different ways. So, initially it checks for credentials from the orchestrator. But, for any reason of it cannot get credentials from orchestrator, It tries to get the credential from your windows authentication. If the credentials are not available there, it prompts you to enter the credentials. That’s the screen that you are getting :slight_smile:

So, to understand why you are not getting the credentials from the orchestrator, there are few things to check and do.

  1. Is your orchestrator connected with the local robot? Since you are in level 3 training, I suppose you have already connected this…
  2. Have you provided a credential asset in Orchestrator - in your screenshot, I can see you have done this which is fine :slight_smile:
  3. In your config file, have you specified your credential asset under the Settings sheet? Here, under the value column, we should specify the exact credential asset name you have in your orchestrator. In your case its System1_Credential. For the name, give a name for that. For example lets say you are naming it as “ACME_Credential”.

One example here:

Now, in your Login.xaml file, I believe you are already passing the Config as an input argument for the login.xaml. In Login.xaml, you have an invoke workflow activity to invoke the GetAppCredential. There, it is asking you an input argument right. For that you have to specify the name you gave for the credential asset in your Config file. In my example “SystemCredential”
You should give it as:
This will look for the asset under this name and go and look for System1_Credential in your orchestrator.

Once you follow these steps, it should work for you like a charm :slight_smile:

Let know how it goes…

If it works, make sure to mark the answer as the solution too :slight_smile:

Thanks alot for Clear explanation.

But still I am stuck
1.orchestrator connected with the local robot? - Yes

. As you said, I tried to System1_Credential = in_Config(“System1_Credential”).ToString
3. In config file, I have added now asset in the settings sheet . I thought to use System1_Credential both in orchestrator and also in the activities of Get APP credential and Login.Xaml .

Please correct my missings

Hi @Leela_Javvaji

You don’t need to change anything in the GetAppCredential.xaml :slight_smile:
Only thing we have to consider is the Login.xaml and where you call the login.xaml file.

Check these files which I have attached and change yours accordingly :slight_smile:

ACME_Login.xaml (14.0 KB)
GetAppCredentials.xaml (13.3 KB)
InitAllApplications.xaml (6.7 KB)

Just to note: in my config: i have used ACME_Credential instead of System1_credential. Just make sure you don’t get confused…

Let know whether this helps!!

My doubt is why my script is not fetching credentials from Orchestrator eventhough its showing as connected and licensed

Config file:

Login.xaml (15.2 KB)
GetAppCredentials.xaml (12.0 KB)

Sorry if I am asking too many questions. I am just trying to understand where I missed

HI @Leela_Javvaji

Your GetAppCredential file looks fine. The Login file also seems to be fine. Now, what I want to see is the xaml file which you are calling the login workflow. Is it the InitAllApplication.xaml? Can you share that as well? I need to see how you are calling the value from the config in there.

PFAInitAllApplications.xaml (5.1 KB)

Hey Sorry…I am trying to execute Login as individual workflow. InitAllApplication doesnt have call to Login

HI @Leela_Javvaji

Well if you are trying to execute Login.xaml as an individual workflow, then you have to prodivde default values to your arguments.
Provide the credential data like this. You may also need to provide the site URL as well because your login.xaml do not know the website unless it is passed through the argument

This should work for you


Login.Xaml executed fine but its not getting credentials from Orchestrator like earlier and its prompting for windows password (2nd route -As you explained earlier)

I have given direct URL @ in_System1_URL - hence browser opeened for the same

As I am not able to fetch user details from Orchestrator, unable to enter same in username and password when I ran the login.xaml

Sorry. May be I am confusing. Not clear where I am exactly doing mistake.Thanks for helping

HI @Leela_Javvaji

Can you share your login.xaml and GetAppCredential files again (latest version you have) so I can have a look and see why it is happening?

Login.xaml (15.5 KB)
GetAppCredentials.xaml (12.0 KB)

I just cross checked and understood that GetAppCredential is working fine as its fetching credentials from Orchestrator( Understood by using Write Line activity for Username field)

Whereas the same values are not getting invoked at Login.xaml (Checked by using same write line activity)

Hi @Leela_Javvaji

This should work… :slight_smile:
It works in mine…

Login.xaml (15.6 KB)

Let know whether it works for you…

1 Like

Hi @Lahiru.Fernando
Can I know changes you made. Reason for asking I just downloaded Login worflow which you have replied on now and ran the script(just by editing Getappcredentials path) and it throws error

So want to understand changes made


I only changed the Invoke activity of the GetAppCredential. I also got this error when I initially tried. But I did some changes to my project.json file and it went off. Looks like there is a version gap between the two studio’s you and I are trying… Can you share your project.json file? I can have a look there for changes…

Hi @Lahiru.Fernando

Finally Login.xaml is working :slight_smile: Change I made by looking at yours is assigning default values after import arguments@GetAppCredentials

project.json (711 Bytes)

Attached json as well.

Thanks alot for your help. Now I can continue with the assignment.:slight_smile:

1 small doubt.

Why in_System1URL is not fetching value from config file?For the script to run I gave value in default

1 Like

Cool… If it is working now, let’s not change the project.json :slight_smile:

So from above, if there is any answer of mine that helped you to resolve the error, please make sure to mark it as the solution too… :slight_smile:
it could greatly help others in situations like this

Yes. Good question. So you initially told me that you are trying to run the login.xaml file individually and you haven’t invoked it from InitAllApplications.xaml file. So to get the URL’s and stuff from the config file, use an Invoke workflow activity in InitAllApplications.xaml and invoke your Login.xaml there.

In the invoke activity, for the URL argument you have here, provide the URL location in the config file like this

Additionally, From the config file screenshot, I see that the system URL is under the name “System1 URL”. One thing you have to note here is, when providing names, you should not include spaces in-between. So instead of the space, introduce “_” and make it “System1_URL”. This same thing should apply for your SHA1 URL as well. it also has spaces…

1 Like

Thank You so much @Lahiru.Fernando

I will continue to work on the assessment further so that hope to learn more :slight_smile: