UiRobot.exe file does not run in UiPath Studio Community version 18.2.3

robot

#1

Hi there,

Just started Orchestrator training, I have been trying for several days to run the UiRobot.exe file without much success.

I have read, followed and tried the instructions given in almost every post within the forum regarding issues related to UiRobot and got nowhere with any of it.

List of things i have tried:

Clean reinstall x 2
run service from cmd - services.msc
run service from task manager
run service from poweshell
run directly from folder as user or admin

In this UiPath Studio Community version 18.3.2 I have noticed, as attached below, that the UiRobot.exe icon is white (or blurred). I am guessing perhaps incomplete or corrupted within the setup file.

and when trying to run it from the folder as user or Administrator, from cmd or powershell, a cmd window pops up for a second or two and disappears again.

and when trying to run the highlighted application file

I get this message, even when i disabled windows firewall

I really need your help with this issue. Dont know what else to do.

Many thanks in advance


#2

Are you saying you don’t see ‘Ui’ icon under system tray after running ‘UiRobot.exe’? Just wanted to confirm.

Thanks,
Rammohan B.


#3

Hi Rammohan, thanks for your reply.

I am able to see it and click on it as user and admin but to no avail. It does not respond.

it appears in the system tray, but does not connect

tried to activate from task manager and services.msc but no luck


#4

sorry about the confusing background windows.

this is the image i meant to send

image

as you can see, uirobot does not appear in services or task manager


#5

Hi there,

After fiddling around, i managed to get the robot to work.

A few things that might help others finding themselves in a similar situation.

  1. if using community studio, forget about trying to install or run the robot from the command prompt. Chances are it will not work and you dont need it anyway.

  2. You can run workflows from the robot in your machine and from orchestrator, even if the robot does not appear in your services.msc window or task manager. Just make sure UsoSvc (Update Orchestrator Service) is running.

  1. Use a file search registry app like (quick search or everything) to find uirobot.exe file. These packages are useful because uipath installer may hide (as it did in my pc) the folder where the file is located. Click on it as user or admin and check in the quick launch window for the ui robot.Try a few times or wait a few minutes until it appears. Then just follow the instructions given in the video tutorials to connect the robot to orchestrator.

Hope this helps someone, Good luck !!