Robot Icon not present in systems tray

robot
p_notaproblem
tray

#1

Scenario:

I am trying to connect my robot to Orchestrator by entering the robot key and Orchestrator URL into the robot’s settings.

Current Behavior:

The UiPath robot icon is not present in the systems tray, and so I cannot access the settings. This is the case for several of my coworkers.

Studio/Robot/Orchestrator Version:

2016.2

OS Version:
Windows 10, 8 and Windows 7


Cannot find UI path icon in system tray!
#2

Run UiRobot.exe /tray from cmd or shortcut (or --tray, depending on your exact Studio version). File is located in Uipath installation folder.


#3

Thank you for your answer!

So, to be clear, what do I write in cmd? “Start UiRobot.exe /tray” ?


#4

It needs to include full path to UiRobot.exe or you need to navigate to it’s folder first. Start is not required.


#5

I see, thanks! Any clue on how to find UiRobot.exe? I am only able to find “C:\ProgramFiles (x86)\UiPath Studio\ UiPath Studio.ink”


#6

It should be in that folder…
obraz

If you can’t find it there, either it has been moved (I’m checking on 2016.2.6232) or you have a different problem and this is just a symptom of it.
Try searching from folder explorer in the installation folder.

Edit:
Opening UiStudio should start the tray as well, so you could try that as a workaround if you need to get it working ASAP.


#7

Ah, I found it, my bad. But when I run the command, I get the error “The term x86 is not recognized as the name of a cmdlet”. I tried all of the following versions:

C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe /tray
C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe --tray
"C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe" /tray
"C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe" --tray
"C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe /tray"
“C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe --tray”

The two last ones do not return an error, but the icon still does not appear.

When I click “customize” in the systems tray, the UiPath Robot does appear in the list. When I set the behaviour to “Show icon and notifications”, I get the info message “This notification icon is not currently active”.


#8

Alright, so this one did the trick:

start “C:\ProgramFiles (x86)\UiPath Studio\UiRobot.exe” --tray.

Thank you for your help!


#9

In Windows 10 I had start the tray function manually by double clicking the app(UiRobot) from below path
C:\Users\username\AppData\Local\UiPath\app-17.1.6435


#10

I am having the same issue. I do not see the UiPath folder on my C Drive in either Program Files folders to accomplish what I have read here. I am using the Community Edition of studio and have setup a tenant, but I still cannot get a robot icon in the system tray. I am in the process of teaching myself UiPath through the training modules and completed studio, Trying to now complete the Orchestrator, but I am stuck at this point. I am using Windows 7 as my OS.


#11

Try pasting the following link into the address bar of your file explorer:
%Userprofile%\AppData\Local\UiPath

After opening that folder, go ahead and open the most recent subfolder named “app-*”, e.g. “app-17.1.6522”. Within this folder you should be able to locate the “UiRobot.exe” file. Double click it. Check your systems tray and see if the icon appeared.

If that did not do the trick, try the following: hold the “Shift” button down while right clicking on the UiRobot.exe file, and click “Copy as path”. Then, write the following command into a command prompt:

start [PATH] –tray
where [PATH] is replaced with the complete path to the UiRobot.exe file that you copied above, surrounded by quotes “”.


#12

It worked! The first option. I will now start over with my orchestrator training. Thank you VERY MUCH:slightly_smiling_face:


#13

This presents a usability problem for end users. The system tray icon used to automatically appear because of how the installer configured it, and now it doesn’t. Yes there’s a workaround, but how do we get this acknowledged as a defect?


#14

Thank You so much . It helped me resolve my problem


#15

thank you so much!


#16

The lnk or link file will appear on windows , when the environment infected by virus . This is common for all apps and files


#17

Hi TDagsvik,
by the above comment i was able to find the UI Robot, but neither double clicking is working nor the cmd thing giving error as system could not find the file


#18

Thanks so much, it resoved the issue.


#19

im using UI path version 2018…no such subfolder with name starting with app exists…
there is a cache file, configuration file, ui studio settings etc but not app* file.


#20

ok its in my C drive program files 86… i have got ui path icon in my system tray
thank you :smile: