UiRobot Agent service not running for Community Edition

robotservice
community

#1

Hi

I have seen similar posts to this but not one that helps me resolve the problem. I have completed the Foundation training am going through the Orchestrator v2016.2 on-line training. I can’t complete the practices that use the free on-line Orchestrator, as I’m unable to start the UiRobot Agent service, to configure the robot agent to connect to the on-line Orchestrator.

From what the documentation and other forum posts state, there is supposed to be a UiRobot Agent service installed when I installed from the Community edition install .exe (UiPathStudioSetup.exe) but this didn’t happen for me. I’ve tried running UiRobot.exe /tray as has been suggested, but this doesn’t work.

On-line documentation refers to other command line parameters to install various features, but I can’t see what options to take.

Running bots locally from UiPath Studio works fine. I am the adminstrator of my PC. I am running Windows 10.

Please help!!


#2

Ok, so I’ll admit I’m being a bit dense, as new to Windows 10 . I have now located the system tray icon for Uipath Robot in the hidden tray icons! There is still no agent service running though… I’ll update when I’ve managed to connect to the UiPath on-line orchestrator and successfully get a robot running.


#3

If its not available under system tray, navigate to ‘%Userprofile%\AppData\Local\UiPath’, check for ‘app-18.1.3’ folder and run UiRobot.exe. It should start the UiRobot under system tray.

Let me know if it works.

Thanks,
Rammohan B.


#4

Hi Rammohan91, mny thanks, I did just that and eventually found the system tray icon and have successfully provisioned a robot in Orchestrator for my PC.

I don’t yet though have an service listed in Services, but not sure yet whether that will be an issue.


#6

I am having the same issue running UiPath Community v18.2.0 under Windows 10. I am trying to connect a Robot as a WCF service as shown in https://www.uipath.com/kb-articles/start-process-from-.net-applicationby adding the address of UiPath Robot service net.pipe://localhost/UiPath/service/MEX to the service reference but the service is not running even when I am running a workflow.