UiPath Orchestrator Login - An Error occured (#500)

We are getting the following error on Login into UiPath Non-Prod On-cloud Orchestrator from yesterday onwards. The same login was working fine till 12/21. No changes in the server after 12/21.

The username and password are typed correct. The database connection behind is working fine. Can you please advise us on how to fix this issue ? This is the Show-stopper for us as we are unable to run the Test bots before Prod migration.

We tried resetting the IIS, Recycling the Application Pools, Restarting the Server and the UiPath Orchestrator site. None of the steps helped us. The Database is connection is fine.

1 Like

Hi @itsmeram
perhaps these threads may help:




Did any of these resolve your issue?

@itsmeram

hi, could you please let me know how did you solve this? I am stuck with the same issue

Hi Everybody
I got this same problem.
Any resolution for this ?

It’s interesting,because after this error if i refresh the website i cen get in.

Hey @MichalB

Can you check if you can log out as well, or you get error on log out to.

If that’s a scenario, Please reinstall your Microsoft .Net Core 3.1.3 – Windows Server Hosting using command line prompt OPT_NO_RUNTIME=1

Hey @Lakshay_Verma

I my case the error is only when i’m log in, when log out there is no error.
I reinstalled the Microsoft .Net Core 3.1.3 with this parameter but this doesn’t help.

@MichalB

Hey,

If possible please share event logs from machine you are trying to log into Orchestrator.
Please filter logs for UiPath, orchestratora and robot only in application logs…

Steps to get Logs

https://support.microsoft.com/en-in/help/302542/how-to-diagnose-system-problems-with-event-viewer-in-microsoft-windows

I attach the file with logs.
I hope is that You asked for.uipath_logs.7z (10.6 KB)

@MichalB

Seems like a issue with user role.

Are you using windows credential to login or is it a sso login.

One thing for sure is, Your credential that you put for the first time is not accepted by Orchestrator as per logs.
This happens when login failed due to invalid credentilas.

Abp.Authorization.AbpAuthorizationException: Current user did not login to the application!
at UiPath.Web.Common.Authorization.UiAuthorizationHelper.d__2.MoveNext()
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()

@loginerror If you can help a bit here.

Thats what i has done exactly to log in:
1.I log in to Windows Server(using domain credentials).
2.I go to orchestrator website and there put credentials for my orchestrator account.

If I try to log in to orchestrator from my office notebook i got exactly this same error.

Now i know that there is more errors ,for example : i can’t add new user

Can you try login as Host in orchestrator.

Please see below link for ref:-

IDM

I can get in to host tenant but i can’t get to IDM.When i’m changeing url and hit enter it’s going back to previous url .
I looks thats its unavailable.

All this problems starts when server was restored from VM’s snapshot.

@MichalB

Did you also change SQL Server or change/moved UiPath Database

Hi @itsmeram
This error occurring due to your storage issue also .

Check Your DB storage partition capacity (where your .ldb & .mdb file saved)
may be not enough space to write the logs and execute.
[this is one of the reason]

1 Like

SQL Server is on other Virtual Machine and wasn’t change/moved.

@Lakshay_Verma

I was following this configuration and all was fine until step 16 becouse i can’t get in to IDM.
It’s looks i have all old entries,browse it but can’t add new values like users,packages …

@MichalB

This might be last option that i see,

  1. Go to Windows -> Run -> Type in “Inetmgr”
  2. Expand Sites -> Select the Orchestrator website -> Right Click on it and click on “Explore”
  3. Now look for web.config file, and make the following changes as explained below.
  4. Set the CustomErrors mode to = “Off” as shown in the screenshot below. (Make sure it’s capital “O” and small “f”)

  5. Set the httpErrors errorMode = "Detailed" as shown in the screenshot below. 

       After making changes in the web.config file and save it. 

           6. Again  open the previous opened IIS. Restart the Website.