Getting HTTP 500 Internal Server Error while trying to authenticate with Orchestrator API

orchestrator
api

#1

So I’m getting a 500 Internal Server Error when I call this web service to authenticate with the Orchestrator API with the following parameters as explained in the UiPath Orchestrator Documentation:

https://staging.uipath.com/api/account/authenticate

Here’s my request body:
{
“tenancyName”:“my tenant name”,
“usernameOrEmailAddress”:“my email”,
“password”:“my password”
}


#2

That tenancy name looks wrong. Are you sure the \admin is in tenant name?
Values should be exactly the same as with normal login.


#3

Hello, I’m getting the same error.
I tried creating tenant with a different name, I did also create different user than admin, but still I’m getting the same message.


#4

@qateam ?


#5

Hello,

@UmerQaiser From what i see there is no tenant with name “uipath_tenancy01/admin”. Tenant name is “uipath_tenancy01”. You could not create a tenant with this format "uipath_tenancy01/admin"
Hope that you solved the problem.
Maybe it will be better to try the login in the interface before going to API
@joni i think that you don’t have the correct tenant/user/pass combination

Thanks,
Cosmin


#6

I have the same issue,

When i do the HTTP request from Uipath studio it works fine.

but I do the request form lets say “https://www.hurl.it/” or self developed HTTP requester application it does not work !. or in other words I get the “Internal Server Error”.


#7

Hi,
If it is working from UiStudio and not working form other third party apps then is a problem with those apps. Maybe some of them do not work well with JSON or HTTPS.
I didn’t face any problem using UiStudio HTTP request or Postman.

Thanks,
Cosmin