Server Error in '/' Application or 500 - Internal Server Error - Troubleshoot steps

Issue Description:

While browsing the Orchestrator website hosted in IIS it is showing 500 Internal Server Error. I am not getting what exactly went wrong even after successful installation of the Orchestrator.

Troubleshooting steps

Error 500 is a generic error:

Please follow the below approach to find the root cause of the issue :

  1. Go to Windows -> Run -> Type in “Inetmgr”
  2. Expand Sites -> Select the Orchestrator website -> Right Click on it and click on “Explore”
  3. Now look for web.config file, and make the following changes as explained below.
  4. Set the CustomErrors mode to = “Off” as shown in the screenshot below. (Make sure it’s capital “O” and small “f”)

  5. Set the httpErrors errorMode = "Detailed" as shown in the screenshot below. 

       After making changes in the web.config file and save it. 

           6. Again  open the previous opened IIS. Restart the Website. 

               Restarting the website ensures that the changes take effect. 

- Now browse the page and troubleshoot further.

All possible scenarios to be included.

In case if you receive an error like 500.19 after disabling the custom logs, please find the solution
One of the reason is, new installation, you have not enabled necessary roles & features.



Solution 1# In case you get the details error as below :

Solution Approach :

     Once done kindly follow the below approach to apply the settings in Orchestrator. 
  1. Open IIS -> Orchestrator website -> Connection Strings

  1. Connection Strings (update the connection )

  1. Provide the server name , database name , username , password which is used to connect to the same database.

  2. Follow the same approach for both the connection string.

  3. Restart the website from IIS.

This will fix the issue. Now launch the Orchestrator

Solution 2 : Verify the Application Pool details & reapply

Navigate to:
IIS -> Application Pool -> Advanced settings -> Identity -> Custom Account -> Set Credentials -> Provide Domain\Username & password.

Recycling option of the Application Pool (Right hand side option is available. )

Below screenshot for reference.

Solution 3 :

  1. IIS → Orchestrator website → Bindings → Select https bindings → Check SSL certificate → Select the appropriate certificate → Restart the website

Ideally Solution 1st , 2nd , 3rd solution approach would solve the issue, thereafter follow the below:

Solution 4 :

Troubleshoot Steps (If all above have been configured properly)

  1. Verify Application Pool Status - Started / Stopped (RUN -> inetmgr -> Application Pool) .It should be Started status & managed Pipeline to be Integrated.

  1. Perform an IISRESET


5 Likes