UIPath Level 3 Training: SHA1 browser does not open

I am currently doing the Level 3 Training project on Security Hash.

For some reason, everything else works but the SHA1 browser window does not open at all.

Also, I put a message box and Write Line activity right before initialize all applications, but these are not executed at all.

What could be causing this?

Its working fine. Your log out was erroring out due due which the control does not go all the way to that part.

SecurityHash.zip (514.5 KB)

Issue: Your attach browser for logout was incorrect

1 Like

Hi, I could not really understand your reply, could you clarify or rephrase it? Thanks

Can’t open or view the attached file " page doesn’t exist or is private"

Also what are the specific steps to fix the workflows?

ok, you are doing a login and logout after that doing your processing.
Your logout was failing due to which the process was failing.
It has been fixed in the attached zip. You can run it and see.

What is this? when you try to download the zip?

The logout click was not correct. So fixed that only

1 Like

Yeah when I try to download the zip i get that error

Could you reupload the file? Thanks

I’ve tried all kinds of stuff to fix the attach window and click logout button but no effect. The selector validator says it should work but nothing is happening

Hi, I’ve resolved that part…

Now the workflow is stuck again. It just stops at the SHA1 Online page and does nothing. Please help troubleshoot and identify where the bug is

See attached file

It erroring out due to below:

You have to remove all queue related actions from your project: (like below)
image

1 Like

Removed it already… still does not work

Fixes:
Missing mapping

Extra “/” in the URL

Navigate to WorkItems, SHA1 Get Hash Code and Extract Work Items attach browser incorrect(you need to indicate the body of the browser not the frame)
image

Client data extraction you have not done the mapping to out arguments

IMed you the zip. Please check

1 Like

Here is the zip file with the edits…

Now it opens every work item file, opens the SHA1 site, does nothing, closes it and moves to the next one. How do I fix this?

1 Like

Have you done the out argument mapping ? because i tested ad it was working fine.
It updated and moves to next one.

See the ClientDataExtraction flow. make it like below.

Also do add a 'message box to see if all 3 values are coming out.

I tested and the values are at 1, 2, and 3 not 0, 1, 2

I did the argument mapping and added a message box… the workflow did not even get to the part with the message box.

I sent you in IM with the above fixes. check it out :slight_smile:

Hi, I ran your workflow and everything seemed fine except that the work items are not updated with the security hash and the “Completed” status on the Acme system…

share what your output panel shows. im sure there is some error.
For me it was working well.

1 Like

I encounter these errors when I run your workflow…

Hi, did you manage to reproduce the errors above?

I think in one of your flows you are using a Go Back activity.
Its SHA1Online_GetHashCode. Can you remove it? and then run again

1 Like

I removed the Go Back activity… now it works but only sometimes and is inconsistent. Not all work items are updated with hash and marked as complete. It takes a few retries to handle most work items. I uploaded the project on the UiPath academy tester and didn’t do so well

Could it be because for every work item update the workflow logs out and logs in again? The process is supposed to log in and log out only on first run (if Config is Nothing) but somehow it keeps logging out and logging in again for each new work item. How do I correct this?

SecurityHash.zip (527.3 KB)

By the time i look at your service, can you show what your output panel looks like?
Are there any errors?