Problem with assignement 1 of level 3 (Calculate Client Security Hash)

Hi all,
I’m frustrate by this module. Indeed, I’m working on this module since already one week, but it does not work.
However, I created the process as it’s explain in the PDF file (as the document is not always clear) and using the Framework.
When I run the process, He doesn’t work and I have error messages as you can see on the attach file.
Problem%20with%20Hash%20calcul%20process

So, if you have a solution for my problem, I would be thrilled.

1 Like

Hi @MigT

The first error you are getting comes from a bad path.

The second one comes from the closeAllapplications module, check out its arguments

The last one is done by Killallprocesses… it seems like you are passing through arguments a browser… you just need to put a kill activity inside it… with the value ofcourse… for example if you want to kill IE use that activity with value “iexplore”

Kind regards,
Pablo

Thanks @Pablo_Sanchez,
however I try and try again to found where is the problem exactly but without success :frowning:

Hi, can you verify if your Config file is present in the project Data folder?
In your Init process the config file is loaded and i think its not there.

Rest are just when the process transitions to the End Process state where you have Logout so its tying to do that and its not able to do so as its not open in the first place

Thanks @nadim.warsi, i checked but the config file and he’s present in the project Data folder…
I change some things again but always the same error messages.

This is very high level information.

Please provide more information or

Use the debug feature and see where your workflow stops or you can try Log Message activity and see after which state the workflow is failing you can see logs in Output Pane

Thanks,
Prankur

Yes, more details will be required.
Can you share a print screen of the arguments in Init state where you have invoke of InitAllSettings.xaml ?
Also a screen of your config file.

Thanks @prankurjoshiand @nadim.warsi
I attached a print screen of init arguments state and of Config file.

I used the Debug feature and the problem is (in the first time), in the InvokeKillAllProcess, as you can see below:

and i forgot to attach the killallprocesses bug:

what do you have inside your Invoke KillAllProcess? it seems some validation error.
Are all activities correct?

The invoke does not take any argument so the invoke seems fine.

I found the problem in KillAllProcesses, it was just an incorrect argument but now the problem is in the System1_Close, as you can see here:

I don’t understand why I have these problems because it’s supposed to start with open browser…

Yes, you are right.

But KillAllProcess helps the bot start fresh. I can suggest to remove the logout invoke in the KillAllProcess and just keep ‘Kill Process’ activity.

Logout should be part of the CloseAllApplications and not KillAllProcess.

I hope you get the logic for the above.

Here that’s in “System1_Close” @nadim.warsi not in KillAllProcesses.

To be clearer, when i used the debug feature, I need to have my browser open with system1 and SHA1 Online pages open and login. So the program run correctly, logout and close pages but after I have an error message because the browser is closed and so he can’t found the browser with web pages open.
For me, it should to open the browser and then to login, run the process… and at the end to close and kill all applications.

The first part of Init State is right for you?

Actually what i wanted to explain to you is here.
image

Can you share what is inside your KillAllProcess?

sure, here you are:

I run Debug in slow step, and I see that in init statement it goes to “system error” that’s why he don’t start the process in the browser

why do you have the invoke in a attach browser? it will not be required. Just use invoke and KillProcess(iexplore.exe)

Once you remove that test once and without debug share your output panel logs

Thanks a lot @nadim.warsi, it’s really better…
Now he run without errors but I have this message (below) and I don’t see the web page open, data extracting… and no data in my excel file.

Capture

Ok, have you removed the logF_BusinessProcessName from your config file?

Yes, I removed it.

Add it back. Or in your init remove the log activity that uses it.
i will suggest add it back and give a meaningful name to the vale in the file