Assignment 2 level 3- - http://www.sha1-online.com not responding

Hi,
I am completing the level 3 UiPath training and cannot get - http://www.sha1-online.com to load (in normal web browser). Is this just me? I cannot complete my training while the page is down, is there a work-around?

2.2 Process Map of Client Hash step says:

Open the SHA1 Online webpage - http://www.sha1-online.com/, and provide the following input: [ClientID]-
[ClientName]-[ClientCountry]. Replace all the variables with the corresponding values. Use dashes between items,
as shown above.

Currently the site appears to be denying everyone.

In the mean time, hashing can also be done by invoking python code.

This site has some information about hashing with python:

Hi everyone,

Trying to open sha1,but it is giving connection refused error in the browser.can any one help me out in this.

@Goutham9292 @rankifyhc

It seems like the site was down. Could you please check after sometime.

The website is down. Same error for me too

Site is still down…

Is it possible to use another sha1 generator website for Calculate Client Security Hash exam or will it be denied after upload to academy server?

1 Like

Indeed, site is still down. Is it mandatory to use this site for the test?

@Reginald

If you are working with Level 3 assignment “Client Security Hash” then this site is needed.

Yes, I’m working on the Level 3 assignment too. So in case we are not allowed to use an alternative site (e.g. https://www.browserling.com/tools/all-hashes ) we face quite an issue. We all cannot finish Level 3 because of that. Any suggestion about how to go ahead?

@Reginald

Sorry I don’t know about this site. We can use for this assignment.

@loginerror @Pablito
Is it possible to use above mentioned site to generate hash code.

@Pablito @loginerror any updates on this issue?

The site does not work yet. Still down!

1 Like

Hi Guys :slight_smile:
Sorry for no feedback. Of course we got your information from very beginning. Unfortunate SHA1 site is global open website and problem is not caused by UiPath. Our team is working on solution for this situation. Sorry for inconvenience.

2 Likes

I come with an update :slight_smile:
Our team checked everything and you can use this website:
https://passwordsgenerator.net/sha1-hash-generator/

Important: It’s important that the hash has to have the characters in lowercase which might not be how it generates based on the website. So please remember to use “.ToLower” in hash string.

4 Likes

I’ll give it a try, thanks!

1 Like

Thanks for your help and it works! Successfully finished the session!

Perhaps consider making this a banner in the academy forum page?

www.sha1-online.com is working again

1 Like

Just a heads up to anyone seeing this in the future, after sha1-online was back up I tried to use it and it was much more difficult to work with than what @Pablito recommended: https://passwordsgenerator.net/sha1-hash-generator/

I had a number of issues with sha1-online once it was back online (pun intended) including the “hash” button being unresponsive, no clear button, and slow loading time. I found the passwordsgenerator to be much quicker and played nicer with UiPath and would recommend all to use it in the future. However, I did need to manually click on “generate” to ensure I get correct hash as the site updates hash as you type and sometimes uipath would retrieve hash too soon.

IMPORTANT if using passwordsgenerator you must convert hashcode to lowercase ,ToLower(), or the assignment will fail 0/100. UiPath should fix this on their end if you ask me though as this is just bad programming for assignment verification.

1 Like