UiPath installed locally on Server - Unable to run processes when Remote Desktop Connection is closed

Hi UiPath Community,

The company I work for have just started their RPA-journey, and I have the pleasure of being responsible for it. However, I am rather new to the universe of RPA and I need some assistance.

For our current setup, UiPath Studio is installed on a local server, which we access via a Remote Desktop Connection. This works extremely well and we have developed a couple of unattended processes, which we would now like to test for a period of time. The processes have to run on a daily basis, which will be handled by Task Scheduler for now, as it is only a few processes and we have not invested in Orchestrator yet.

… and now for the challenge: I try to run the processes via Task Scheduler while being disconnected from the Remote Desktop Connection, but the processes stops/fails. Seems like UiPath is unable to find the elements, e.g. click on a ‘Run’ button when opening our ERP system. If I am connected to the Remote Desktop Connection and start the process either through UiPath or Task Scheduler, then there is no problem.

I have tried to select ‘SendWindowsMessages’ and ‘SimulateClick’ in ‘Properties’ for a Click-activity. I have also tried to use Send Hotkey, but nothing seems to work.

I have tried to search the internet for a solution but no luck. Read something about ‘Windows Remote Desktop Extention’ and ‘UiPath Remote Runtime’, but from my understanding that is only applicable, if UiPath Studio is installed on your laptop, and the robot needs to access and work in a Remote Desktop, but please correct me if I am wrong.

Looking forward to reading your input and suggestions.

Kind regards,


Welcome to forums,

Can you check the license allocated is Unattended licenses?

If it is then suggest to use Orchestrator as it mandate to run unattended bots, I belive task schedule cannot login when the RDP is not connected, Orchestrator has auto login facility for unattended bots

Mark as solution if this helps


Hi @SimonDalgaard,
have you the CE or enterprise edition? Is important to set up the bot in service mode and not the user mode. if you have the enterprise you can install the service mode via the installer.
Maybe this post can help you:

Unattended bot requires background automation, the error is timeout reached or other type of error?



So Let’s see it from a different point of view.

  • You have a process, and it need a machine to work on i.e your local server

  • It also need a trigger i.e your task scheduler

  • Now last thing you need is a human replacement i.e. UiPath robot

Note : - Like human, robot need credentials to work on machine to login and start working , as you stated your machine is disconnected and robot is unable to start windows session for application to work on.

Hope this clear your doubts.

Happy Automation :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.