UI path update 2019.1.0 causing robot connection issue "Task canceled"

I had UI path mandatory update Yesterday 1/23 and after successful update UI path studio is working fine but whenever I try to connect robot it is giving error as task canceled, possible images are attached.
Other details :

  1. It was working fine with 18.4.1.
  2. I am using home network , there is no network issues as same was working earlier
  3. I have tried options by looking into forum like restarting host from task manager , quit and restart , using other URL https://lts-platform.uipath.com/

Any help on this is appreciated.
RobotError Version1

Hi @vaibhavp2

Strange. Could you try to ping the platform.uipath.com from the command line? Just to be extra sure.

Also, please make sure that the robot service is running from the app-19.1.0 folder. You can see that in the Task Manager after adding the column “Command line”

Would it be possible that your antivirus blocks the new executable file because it considers it a new file (it sits in a new folder)?


Restarting laptop solved problem for me.


Forget network followed by Reset the wifi adapter solved this issue. Thanks


In our case entering the company proxy information in UiPath.service.host.exe.config and nuget.config and restarting the service sorted the issue which started after upgrading to version 2019.4.2 of UiPath.


image What I do is shutting down this two task in taskmgr. Then it works for me, but not 100% working.

Hello, I got the following error yesterday:
message: System.Exception: A task was canceled. at UiPath.Core.Activities.BaseAssetActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result) at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
This happened when running workflow and it was thrown just after all items from the queue were processed.
I’m guessing it may be due to recent Cloud Orchestrator issues.

1 Like

I think this is the right assumption, some of my processes were also malfunctioning (Get Asset was giving me A task was cancelled) but it is all good now.