UI Path Recorder(Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))

recorder
studio

#1

Hi All,

Facing this particular while trying to use the recorder. I am unable to run the existing workflow as well. Kindly help.

Capture


#2

Hi,
Please follow up these post.
Reference 1
Reference 2


#3

Hi Dilip,

These are reference are referring certain specific application. I am unable to even start recorder from the uipath screen. As soon as I click on record button it throughs this error n I am unable to go further n try recorder.


#4

Hi Rachit,

Does this error occur when you open UiExplorer and select something? What kind of recording are you using(Basic, Desktop, Web, Citrix)?

Please provide Studio version and OS.


#5

Hello @Rachit,

Does it meet software-requirements as specified ?


#6

Hi Dilip,

I tried this approach provided by the UI Path’s website “https://www.uipath.com/kb-articles/internet-explorer-automation-troubleshooting” which suggested to install a specific dll but even that didn’t work.

Hence I re-installed the UI Path Studio and that seems to be working now.

All I could deduce was it was giving error as product had some installation issues.

Thank you for your help and valuable inputs.


#7

Hi Ovi,

I was trying to use basic recorder. But none seemed to work. I was unable to open the solution as well which was provided during the training. After numerous attempts and solutions i was not able to find out a way hence I re-installed the UI Path studio. Now it seems to be working.


#8

Yes, I’ve googled this error and saw that it occurs due to improper installation. I’m glad it works now and if it will happen again please let us know.