Error with recorder

Hi there,

I am new to UI Path. I took some basic courses previously and things worked OK. I have now gotten back to training and got a problem. When I use the recorder to open a web browser (Chrome), I get a basic error stating that the step was not recorded successfully. I have checked the Chrome extension and ensured that it the incognito and file URL access options were enabled. It still does not work.

Also, when I enable the extension, when I open Chrome, it tries to reset settings saying that another program had corrupted them. Not sure if this is related.

Any help would be appreciated!


1 Like

@ElenaB - could you please share the workflow - screenshots of it maybe?


  1. did you try the Open Browser activity to open a browser? Try opening a browser using Open Browser and then use recorder to record subsequent steps - test how this goes.
  2. yes, the Chrome extension to be successfully installed and turned On is critical to this - you should double check this

Thank you sumitd. I got no real workflow as it failed so early. I did check both steps you listed but it did not fix it. I then tried to use Explorer and everything worked fine. Something definitely to do with Chrome but I cannot diagnose! I don’t mind using Explorer for this. In a way it is easier as I use Chrome for everything else and then UI Path will not interfere with other browser windows… Still curious what the issue is but now less critical. Wanting to understand how to debug these types of errors…more for general knowledge.

1 Like

The most reliable browser for RPA is IE. For all automations I use it unless it’s something really requiere to use another browser. In my personal opinion IE is the best for it. IE also has incognito.

1 Like

Thank you. Good to know for efficiency!