Error 80040154 UIPath when using Send Outlook mail message activity

Hello everyone,

While using Send Outlook Mail Message Activity , I am getting the error mentioned below.

Error {“message”:“Send Outlook Mail Message : Retrieving the COM class factory for component with CLSID {0006F03A-0000-0000-C000-000000000046} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).”

I am working on Windows 10 (64 bit) and since UIPath studio is 32 bit , I am not able to fix this error. I don’t know how to change the configuration settings.

Please provide suitable guidance on this how to fix this error.


Please check with your client/company IT team, they much have blocked sending email via 3rd party application or they much have changed the Group Policy .

Thanks for the quick response . I have got the trial version of UIPath on my laptop. So can you tell me how I fix this on my system?

It looks like outlook program you’re trying to initialize either isn’t installed on your machine, has a damaged installation or needs to be registered.

Either install it, repair it (via Add/Remove Programs) or register it (via Regsvr32.exe)

if still face problem then let us know :slight_smile:



i am facing the same error. i am trying extract data from website using Data Scrapper and store it in a csv file and send it to my mail but it shows this error can anyone plz help me resolve this.

Hi Adi,

Please verify whether you provided the input mail ID in the properties.


A post was split to a new topic: Send Outlook Mail Message : Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))

Hi @aksh1yadav

I’m using Send outlook Mail Message.But receiving the Timeout error.
Please find the details below:

InvokeSendEmailError has thrown an exception

Source: Send Outlook Mail Message

Message: The operation has timed out.

Exception Type: TimeoutException

System.TimeoutException: The operation has timed out.
at UiPath.Mail.Activities.SendMailActivity.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

  • Current Mail version : 1.2.6863.29868

Please help me why I’m facing this Error Message.

hey @DAishwarya

Are you sending an attachment as well with mail? if so yes what is the size of that attachment.?

Well first call resolution is Try to increase the timeout :slight_smile: and give it a try.

Let me know :slight_smile:


Hi @aksh1yadav,
I just tried to send the mail with no attachments. Also I tried increasing the Time Out. But still getting the same issue.


Close and Open Outlook and run again.