Cannot find Recorder and data scraping tool on my design tab

Hi friends, I just recently installed uipath on my system but couldn’t find the recorder and the scraping tools as well. I have reinstalled several times but it could not be found.Please someone with an idea or solution should help

What version did you install? And could you please show a screenshot of you design tab? Never heard about this problem.


version 2018.4.1 beta 17
Thanks

Thanks, I see there’s a whole lot of errors in the logs, can you paste them here? Might help with finding where the problem is.


The last screenshot was failed to load assembly nuget/packages/uipath.system.activities.dll
failed to load assembly nuget/packages/uipath.orchestratorclient.dll
failed to load assembly nuget/packages/uipath.wizards.dll
failed to load assembly nuget/packages/uipath.uiautomation.dll

I think that’s where the problem is, looks like it’s trying to load older packages which aren’t compatible with the .NET framework.

Couple of things to look at:

  • Do you have .NET framework installed? (at least version 4.6.1)
  • Do you have older versions of Studio on the machine?

Otherwise @loginerror might be able to help you further, as that’s where my knowledge stops :slight_smile:

I have .NET framework 4.5, 4.6.1 and 4.6.2 installed though I have older versions of studio 4.3.2 on the machine but I am currently using 4.1. Pls what should I do now?

I read somewhere that having multiple versions of studio on the machine may cause issues, I think that’s where the problem may be. Can you remove them (or move to a backup if necessary) and try again? You might have to reinstall the newest version one more time.

Aright, I just deleted the versions, I am left with one version which I reinstalled 4.0, it’s still the same issue. How do I get the latest version cos I want to delete all and download newest version

I think 4.0 is the newest you can download, you can get the beta by selecting the beta version on the Help screen.

If this doesn’t work, then I don’t know what the problem is. Someone from the UiPath team will need to help you out further. @loginerror @ovi @badita

Thanks

Hi @RPA-botDev

Could you try creating a new, blank project?

I have done that, yet it’s the same issue

Could you post a screenshot of your entire package manager?

Thanks, I should have been more specific. I meant the Product Dependencies tab :slight_smile: There might be a clue as to what is broken in there.

you mean these?

This error also popped out

Could you try moving the packages out of this folder (removing them will also work, but it’s worth keeping a backup just in case):
%userprofile%\.nuget\packages\
and then relaunching the project?

Hopefully Studio will re-download the correct ones.

3 Likes

Cudos, it has worked

2 Likes