UI Path Data Scrapping not extracting all the rows of data

datatable
uiautomation
activities
datascraping

#1

Hi,

I am not able to scrap all the 2000 rows of records using data scrapping, where I am getting only 16 rows of data. Please help me in this. I tried increasing number of results to 5000 still getting only 16 rows of data instead of 2462 rows of data. Moreover data definition is also same for all the rows checked with selectors.
Web application.


#2

Is your row data spread across multiple pages? If yes then i hope you have given the selector for the next button/link element?

Thanks,
Rammohan B.


#3

Thanks for the reply, No it is not in multiple pages just need to scroll down to see the data i.e., total data is in same page.
image


#4

Does the rows auto loads when you scroll down or all the 2000 rows are available at once in the page? Do you see only 16 rows at a time visible in the screen? Just trying to understand if the table rows itself if visible in the screen for the robot to scrape all the rows.

Thanks,
Rammohan B.


#5

I see all the 2462 records at once, if you see 1st screenshot I posted on the screen there are 11 rows visible but it extracted 16 rows of data. I think it is not problem with table visibility. But don’t know the exact reason for not extracting all the rows of data. Is there any workaround for this, I checked 17th row value with selector, I see its properties are same as the extracted 16 rows values defined in data definition.


#6

Hello @adarsh,

Have you used extract the whole table option or indicated the pattern manually?


#7

Hi Rishabh, I tried both ways the one i posted is with manual extraction you can see single column, I tried whole table as well with which i got only 1 row of data.


#8

Try indicating the first element from the column and then for indicating the second element, scroll down and choose the last element in the column.


#9

It may not be an efficient way but you can also try to scrape the table data using Find Children activity if everything else fails.

Use a Find Children Activity and indicate the table selector. You may have to provide the proper filter tag that filters the particular value for each of the row for a column. Use a For Each Loop on the list of elements and then get the aaname or relevant attributes that has that row value using Get Attribute activity.

Thanks,
Rammohan B


#10

Hi Rammohan,

I have tested iterating in while loop as well, it is getting only 16 rows of data based on the rows visible on screen. 17th row is becoming index ‘3’ if i make it visible by scrolling down and again able to fetch next 16 records. How to handle this in UI path.


#11

Hi Rishab,
I am getting UiElement is no longer valid error. Is there any workaround to get all rows of data from same page (by scrolling down). I tried screen scrapping, data scrapping and While loop get text based on Index still was able to get only 16 rows of data. next after scrolling down the index is again starting from ‘3’ till ‘18’ so it is working on visible sets of data.
image


#12

So all the rows are not available at once to scroll the data table. May be you can first send page down or End hotkey until the scrollbar reaches the end, so that all the rows are visible and then try to scrape the datatable.

Let me know if that works.

Thanks,
Rammohan B.


#13

Hi Rammohan,

I tried this as well scrolled down till end using ‘end’ Hokey and did scrapping then it is extracting last 13 row values in 2439 rows.


#14

Just to confirm. I hope you have indicated the 1st Row and the Last Row (2439th Row) while doing the scraping.

Did you try to implement the Find children activity? Is that as well not working?

Also, Let us know if its possible for us to access that page.

Thanks,
Rammohan B.


#15

Hi I’m having the same issue here.
Was there a fix for this?