Unable to extract all the rows using Data scraping table

I am trying to extract a table from a site using data scraping. But UIPath only fetches first few rows. I tried using scrolling down and then data scraping. But then it only fetches last few rows.

My table is in single page but need to scroll down to seen more rows.

Could anyone please help

Hi,

It depends of your page. I had similar problem on jsp page: the content was “dynamically” generated. Can you provide more about this page?

Try by providing maximum number of results to 0.
Also, when you done screen scrapping are you able to see the preview data with whole values in the page?
Also check the selector.

Hi @nabeelu.
Welcome to the community.
Can you send the webpage url?

Tried providing maximum results as 0. But not working.
Even in preview, its just showing few row items. Checked the selector as well

Problem is its internal website. outside the company we will not be able to access the url

1 Like

Can you provide the screen shots of properties (selectors)

For scraping did you selected the whole table at once or element in the table? also can you open with ui explorer?

I think after capturing the first element you had given the option as yes for the popup “would you like to extract data from the whole table?”. Can you try without giving yes for that pop up and scrape necessary data

I tried both ways. but still no luck

When you look at the page’s code with developper tools, do the other rows appear without scrolling down the page?

Hi,

  1. First of all once you load the webpage make sure all elements are loaded with property set to ‘COMPLETE’ and check the table element exists or not.
  2. Send a hotkey ‘home’ and ‘end’ just to be sure.
  3. While data scraping keep rows as ‘0’ for whole table to be scraped.

That’s all there is to it, but it is better to inspect the table element and see whether the DomXPath is increasing steadily without any abrupt gaps because pattern recognition can work only under the condition that there is no break in continuity.

The workaround would be attribute based extraction and string operation using ‘Find children’ activity and looping through the descendants (you might have to put some conditional statements which will work if the table has loaded properly)

Sometime there might be another DIV inside that table node which might be confusing the data scraper.

Hope this helps :slight_smile:

Regards