Type 'UiPath.CV.CvDescriptor' is not defined

Hi @loginerror … Can you Please help us on this

Can you create a brand new project with a simple CV application scope and activity and test to see if it works, and then post your dependencies?

1 Like

Will try Now

1 Like


Done …But same error :frowning:

@Aqua1986

hi, did you find any definition for this problem?

image

Hey @KMota, the problem isn’t solved yet!

1 Like

I contacted uipath support, I’m waiting for feedback

Same here

1 Like

Hello,

In contact with Uipath support I downgraded the computer vision versions and activity and it worked. 2.0.1 CV and 19.7 system.activities

1 Like

If you downgrade activities as @KMota described, do you find any success?

There is an internal Jira ticket open on this issue for 19.8.0-ce + 2.1.0

1 Like

Just Tried @Kristopher But For me it is not working yet

Please try again when 19.9.x-ce is released (should be before October)

Hi!

This error continues to persist when using 19.10.0-ce.

Workflow ‘xaml’ has the following compilation errors:
Type ‘UiPath.CV.CvDescriptor’ is not defined.

Has there been an update on this issue?

Thanks!

Hi @cvs0115

Could you maybe do:

  1. Create new project
  2. Install dependencies that cause the issue
  3. Verify the issue is happening

We would appreciate if you would then zip the project folder (including the project.json file) and attach it here on the Forum :slight_smile:

Hi @loginerror

I created a new project that includes CV Scope and a CV Click. I kept it as simple as possible and I continue to get the same error.

FYI I removed the API Key before zipping it.

CV-Test.zip (16.5 KB)

1 Like

This is super strange, as it doesn’t happen to me when I open that sample project…

@Cosin any idea here?

@loginerror I get the error when I publish it.

1 Like

Hi @cvs0115

Obviously, my bad :man_facepalming:

I reproduced it on my end. I also managed to fix it by adding UiPath.CV namespace:

With that simple fix it publishes without an issue :slight_smile:

hi @loginerror

i am still getting this error even with later versions of activities pack. is it still being looked into

thanks
Mandeep

Hi @mgarg1982

Welcome to our UiPath Forum! :slight_smile:

This should be fixed by now, I think.

Could you please open a new topic and provide all the information mentioned here: