Type into fails in Ariba!


I am upgrading my robot from 2019 to 2020.

As a part of the process, the bot attaches a file from drive onto SAP (on a browser through UI). A window opens to browse for file and select the file. Like any other upload activity.

I was using a TypeInto previously, but now it seems to fail. I wasn’t using SimulateClick or SendWindowMessage previously, neither I have used it now. The typeinto doesn’t work at all with these enabled.

Also, I tried adding delays, selecting clickbeforeTyping, but nothing works.

Has anyone worked with Ariba before?


May I know what error we are getting

Either we can try with SET VALUE

like copy paste that is pass the value or variable to SET TO CLIPBOARD and use a SEND HOTKEY ACTIVITY with key as ctrl+v to paste the value


There isn’t any error, the bot just does not write the value in the text box.

Fine then
Pls use a writeline activity before type into activity and pass the same input value or variable

And let’s see the value is getting displayed in output panel
If it is coming then it’s something with type into activity
Or it’s with variable having now value in it

Cheers @songoel

The variable isn’t empty. Value is coming correctly. It’s definitely the Type Into.