Type Into activity not working as expected

uiautomation
activities

#1

Hi,
What I am trying to do is click a file download link in a website which shows a ‘Save File’ dialog box. It is required to provide a user defined path for saving file in the address bar. So, I used a type into activity with the properties “active, click before typing and empty field” checked. But the problem is that most of the times, the type into activity is not recognizing the address bar exactly and makes multiple clicks on the file path already existing in the address bar. I tried working out with the selectors with dynamic selectors but the problem is still the same.


#2

@suwalruchan365 Use Http Request actvity and in the properties there is ResourcePath just give path where you wants to download that file


#3

Uncheck the click before typing and provide some delay before typeinto and check @suwalruchan365


#4

This is the selector for that type into activity
‘< w.nd ctrlid=‘1001’ title=‘Address: C:\Users\consult3\Documents\UiPath\Office Project’ / >’
Here, the title value keeps on changing so I replaced “C:\Users\consult3\Documents\UiPath\Office Project” with an * .And for a while it works. But later it either does not work or goes on clicking each value in the path say ‘Users’ or ‘UiPath’ or ‘Office Project’ and does not type in the defined value.


#5

Hi,
I tried it but the problem is still the same.


#6

hi,
I could only find Orchestrator HTTP Request activity and it does not have ResourcePath property.


#7

@suwalruchan365 Install web activities packages


#8

Hi Indra,
I just got the web activities installed. Can you please give me a brief explanation on how to work with the properties panel. Thank you for your help.


#9

@suwalruchan365 check attached file

Main.xaml (5.5 KB)


#10

For these this it has custom activity called “Download File” . You don’t want to pass extra parameter. May be it can help to solve the problem.

check the Third Activity.

Regards
Balamurugan


Unable to Save as
#11

Where can I get your package “BalaReva.Externals.Activities”. Thank you


#12

Hi @suwalruchan365,
You can get the Package as below

Regards
Balamurugan


#13

Hi,
I tried looking for it but it is not listed in the list. My manage package window looks like below:


#14

Hi @suwalruchan365,

Please add this link the in configure source

https://gallery.uipath.com/api/v2

Regards
Balamurugan


#15

Hi,
I tried using download activity from the package you recommended but it is giving an error message as “An exception occurred during a WebClient request”. I have attached the xaml file herewith.

khok.xaml (5.3 KB)


#16

Hi @suwalruchan365,

I thank and appreciate you using the activity. I saw your attachment. The thing is you have to specify the full file path like “c:\tmp\sample.xml” . I Have done the changes that I attached it here.

File :khok.xaml (5.2 KB)

Regards
Balamurugan.S