Type into activity not working in unattended mode

My bot is downloading some.files and saving at different different folder locations.
Using chrome browser, i have changed the settings to ask me place to download.

But on using Type in activity to type the desirednfilder path, it works in attended mode if I dont select simulate type or send window message properties, but then in unattended mode, its is.unable to type in.

If I use any of these properties- simulate type./ sendwindowmessage, it doesn’t type even in unattended mode, but takes the last folder location.

Pls help

Hi

Usually type into activity will work with simulate type enabled when running in unattended mode

Pls share the selector or make sure that

  1. the dynamic part of selector is handled with wildcard symbols *

  2. And include stable attributes like aaname, title along the selector

Hope this would help you resolve this

Cheers @goel.saloni

I’ve found the most reliable way is to use Set Text to enter the path only, then click Open. Then use Set Text to enter the filename and click Open again.

And the file selection window is not part of the browser, it’s part of Windows. So after it opens you have to Attach (or Use App/Browser) it.

Selector -

wnd app=‘chrome.exe’ cls=’#32770’ title=‘Save As’
wnd ctrlid=‘41477’
wnd ctrlid=‘41477’

Hi

Remove those ctrlId and include aaname attribute

We can get that by clicking on three line option menu in that activity and select EDIT SELECTOR

There check and uncheck the attribute names

cheers @goel.saloni

There is no aaname attribute. The ctrlid selectors are the correct way to attach to that window.

true, no aanaae there

It goes to correct folder path if i don’t select any of the settings -
simulate type or
sendwindowmessage

Issue comes once one of these options is selected.
But without checking one of these two properties, If I minimise Vm, it goes fora timeout since not able to type in

Still trying and looking for a solution. I observed thst if I select simulate type or
sendwindowmessage as TRUE, then it doesnt type even when I am actively seeing the page in VM.

What us the correct setting for type In activity

I tried using attach window activity after the save as window opens up…but same behaviour, it types the correct folder path if simulate click / send windowmessage isnot selected, but doesn’t of any one of them is selected.
May be I am.not using the attach window correctly

So don’t use those settings. Also, Set Text is better than Type Into for things like this.

I have to run the vit unattended by orchestrator. If simulate type/ send windowsmessage not used, it goes to time out since not able to do the activity.
Any work around for this?

Hi @goel.saloni ,

What happens if you run in debug, and attempt to retry the action when it fails? Is the failure consistent? If not, it might be worth a retry scope.

An alternative workaround is to set your browser to always download things into the Downloads folder, then move the latest modified file (which will be the one you’ve just downloaded) to the folder you need it to be in using the Move File activity.

I have a generic function that will find the latest modified file for you. I’ve attached it to this post; you should be able to just plonk it into your project folder, invoke it and feed arguments in/out.

GetLatestFileFromFolder.xaml (11.4 KB)

Thanks for sharing your work. Will definately be useful sometime…
But for this robot, i need to download in different folders,sonce rhe number of files will be big.

And for debug it has to be in attended mode, right
I am not getting problem when I am running it in in attended mode, but in unattended mode, when it fails to type in the correct folder path in the location field of save as dialog box

@postwick tried using set text activity. But that is also not typing in the correct folder path,even in attended mode
selector -

wnd app=‘chrome.exe’ cls=’#32770’ title=‘Save As’ />
wnd ctrlid=‘41477’ />

Notice that when you hover around it, there is more than one object where the text field is. When I get the selector for that field, I go to the “deepest” one - I think ctrlid is repeated 3 times.

Yes, corrected the selector . I can see 2 ctrlid.
Set text is still not able to type anything