Type into activity doesn't type whole file path string

I have tried many ways to get it through but “type Into” just doesn’t work. it starts typing characters after symbol like comma , hyphen.
I have tried many combination of delays ,delay between keystroke , type simulate , “window massage” and “click before typing” as well.
any workaround or tip please…!!!

here it should type entire filepath as can be seen in output panel, but it types only " Not Listening"…?

Its working for me…
Do a few things:

  1. Use attach window to connect to the window. (Maybe you are already doing it, cant see it in the screenshot).
  2. For type into select the following check boxes in the properties panel.
    a. Activate
    b. Click before typing
    c. Empty Field
1 Like


Did you try to set the path to clipboard (Set To Clipboard) , then click on the textbox & send hot key Ctrl + V

1 Like

Hi Imran , thanks a ton for your reply , I try it excatly , and type into activity is working , but still it starts typing either from " space" or from “hyphen”.
for example the file path is : “C:\Users\Shuaib\Documents\UiPath\E-Book - Copy\The 4 Day Week”
and it types only : " - Copy\The 4 Day Week".

@Doanh No it didn’t work , here is my workflow , please check it out.
temp.xaml (8.6 KB)

Hi there, I just found a solution for the problem , If i click first to the little downward arrow sign , then text box become editable and it allows typing of other text smoothly.


Although i tried it by first clicking right click button and then clicking " Edit address" , practically , It should work same , but it doesn’t. Somehow above method works flawlessly.

Thank you Everyone…!!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.