The Remote certificate is invalid according to the validation procedure exception

Hello friends!

I am currently testing Orchestrator. The setup is that I’ve created is Remote Windows Server and there I installed Orchestrator.
The problem is the Exception:

The Remote certificate is invalid according to the validation procedure

I’ve done everything from this link:

I can access the Orchestrator from my Local machine, but I cannot connect a Robot to it.

Pictures:

  1. Exception and Orchestrator details.

  2. Self signed certificate with the same name as the Remote Machine

  3. Computer Name
    3

  4. Web Site bindings done with URL Rewrite
    4

  5. Certificate in Trusted Root Certificate Authorities in Remote Machine

  6. Certificate in Trusted Root Certificate Authorities in Local Machine

I think i followed everything right, I can access the Orchestrator from my Local machine but I cannot connect robot to it.

If anyone could help me with this I would be gratefull.

Please try to google the error @srdjan.suc, we will have lot of solutions available.

Can you please confirm if you have any antivirus installed in your machine?

I’ve been looking at forum for last few hours, found few solutions but they didn’t help me.
I disabled anti-virus (Karspersky) but that did not help either.

Note, on Local MachineI have installed UiPath Studio and Robot version 19.8.0, and on Remote Machine where I’ve installed Orchestrator there is just Robot version 19.4.4. and probably the same version of Orchestrator, could this be the problem?

I will try to reinstall UiPath Studio and Robot on my Local Machine to version 19.4.4.

Check that as well and are you trying to connect to the floating robot or standard robot @srdjan.suc?

Hi @srdjan.suc

Check this

Thanks
AshwinS

Here you have lot of solutions for the same topic @srdjan.suc

Standard robot,
I’ve installed older version of UiPath Studio, still the same exception.
Gonna check rest of the posts on this topic

I’ve already installed Certificate in Trusted Root Certification Authorities

Have you checked the above link @srdjan.suc, that contains many solutions. check if any of them helps you and if you are all set, I want you to create a topic with the steps to be done so many of the mates in the forum will get helped by that please

1 Like

@srdjan.suc I am also facing same issue.

@HareeshMR All solutions on web have self signed certificate IssueTo field to some domain.

In my case when I create a self signed certificate, both issued to and issued by are same as machine name.

If on local machine ( on which orchestrator is deployed) I used the machine name in robot settings it works. But if I use the IP addresses, it do not.

1 Like

You need to give Orchestrator the same name as the machine that he is running on.
After that, you need to remove all the current certificates, restart the machine and create new certificates (now that you’ve changed the name of the Orchestrator).

You also need to change binding in C:\Windows\System32\drivers\etc\host file (picture shown below)

Restart the machine one more time just to be sure.
After that you can export the certificate and then install it.

You need to change the bindings in your local machine (C:\Windows\System32\drivers\etc\host) as well (as shown in the picture below) so you can access the Orchestartor .

After that, if you can access the Orchestrator with Machine name where it is hosted on, you can probably connect the robot.

Note, you can probably do this with different name than the machine name where Orchestrator is hosted, but I didn’t test it

1 Like

Thanks. It worked after adding the host entry.

1 Like

Nice! I’m glad it helped :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.