Orchestrator issue!

Hello all

I am trying to contact a robot with Orchestrator but i get the following error:
“The remote certificate is invalid due to validation procedure”

Orchestrator is on a local server.
I tried though my local PC and on the same server and I get the same error.
“The remote certificate is invalid due to validation procedure”

anyone got the same issue and what is the walk around or solution !

Awaiting you kind replays !

1 Like


Check it out and see if helps you:



Thanks for the replay I will try the solution.

Although I search for the issue before i posted it nothing came up, maybe I search in another section of this forum.

Anyway thank you alot.

1 Like

I did export the certificate from server iis and install it on local PC didnt work still the same error.

i have a robot on the same server that orchestrator is installed on still i have the same error.

I dont have the link for the Enterprise Docs

@husain is issue get resolved, if yes what was workaround?

1 Like

yes, you need to export the certificate and then install it on the local PC in the Trusted Root Certification Authority folder.

And it will work like a charm !!!

Best of luck.

1 Like

Hi ,

I am also facing the same issue, so I followed the steps mentioned for installing the certificate in the Local (Trusted Root certificates) and I can see the certificate installed.

But still I am getting the same error and couldn’t able to solve this issue. So any more inputs regarding to this issue would be much appreciated.

@siddu509: I had a similar issue; I had to export the certificate from the Trusted Root folder and installed on the Personal folder, which enabled to be visible in the IIS. Try and let me know how that goes.

Thank you for responding back @PD2. I am able to fix the issue.

My problem with that was naming mismatch for my certificate and URL naming I am providing in the IIS server. once i corrected it i am able to resolve it.

Once again thank you for spending your time.


oh yes the certificate name needs to be the same as the host name; if you issued the certificate to the URL then you will have to create a DNS entry.