Task scheduler + Remote desktop


#1

Hello guys,

we are facing several issues regarding scheduling the robot. The robot is isntalled on the server. We are able to run it manually, but not schedule it. Also when we run it manually, and minimized or closed remote desktop, it fails at the first clicking activity. Let me summarize all questions.:

We are not able to schedule the task. Firstly, we tried schedule it with option: “Run only when user is logged on”. It seems that the robot is not able to see ui elements when the remote desktop is closed. I went through all the topics here and nothing work. My questions are: Should we definitely use Launch workflow interactive activity?? Should we somehow change the uipath.setting file? Should we use “Run whether user is logged on or not”? Should we use something different in command line than \monitored?

Thank you very much for any help.


Deploying bots within VDI environment
#2

Hello @mario,

Maybe this will help,

Regards,


#3

Use only Orcchestrator CE.

Task scheduler will fail or at least will be hard to maintain if you use community due to version control.

The advantages of using the Orchestrator are amazing, give it a try

i guess is this one

https://demo.uipath.com/Account/Login?returnUrl=%2F


#4

Hello!

I have a different link here to Orchestrator CE. I don’t know if both works, but here’s my just in case:
https://platform.uipath.com/Account/Login?returnUrl=%2F


#5

Thanks for answers.

I have already read that article hot to schedule process manually. It didnt help.

Are you telling me that there us no solution for that? I am not even able to test it in studio. Like I said, when RDT is minimized it doesnt click on anything


#6

Are you running inside the machine that you access with RDT? Or are trying to automate outside?


#7

what is the difference?


#8

If you’re automating the machine and just accessing it through RDT then the fact to minimize it shouldn’t cause any problems. But If you’re trying to automate the window of the RDT, you’re working like a Citrix Environment (VDI), so Uipath will not be able to identify the elements since it’s working with images if you minimize it.


#9

The Robot was actualy developed on local machine and then transfered to the server. But now when I want to run it several things are not working.

The most important is the ui element interaction. The robot is not able to click on anything.


#10

Have you tried to do the click again but this time on the Server Machine just to be sure that works? Maybe this change should have affected the developing and the server has different Ui Elements depending on the system that you are working for.


#11

Of course. The robot runs successfully if I am sitting at the computer and watching the screen.

Once the screen is not “turned on” it fails.


#12

HI @mario were you able to find out any reasons/solutions for this issue ?


#13

Hi juvaraja.

I think we did. At one client we were successful. The second one has probably some restrictions from IT side. Basicly it is about correct configurarion of virtual machine. E.g. We used this

http://blogs.microsoft.co.il/arnona/2016/01/03/keeping-an-active-desktop-session/

Or a mouse clicker app which moves by one picel each 100 seconds


#14

Mario,

Lots and lots users are facing this issue. This is one of big limitation of the UiPath tool. You can not schedule a project in disconnected mode (when virtual machine locked or disconnected). Even if we use launch interactive workflow, it is not consistent in behavior.

We are also getting similar issues. Without capability of running the bots in virtual desktop will defeat the purpose of automation

If you find solution, please feel to copy me in the solution. We are looking for this solution ASAP

Regards
Pawan.


#15

Hello,

We did find the solution.

Have u tried my link above?