Task Scheduler Problems


#1

Hello,

We are trying to run a process periodically with UiPath using the task scheduler. There are two options in order to do this, running the process only when user is logged on and running the process whether user is logged on or not. For this process we have to run whether user is logged on or not.

In UiPath webpage there is some information about how to configure the task and the user in order to run a process whether user is logged on or off. We have done all the necessary steps mentioned there (Logon as batch job is set and add new generic credentials with its correctly format) but there is some problem because the process only runs with the option “run only when user is logged on”.

We don’t know which is the problem. Do you know any solution for this?

Thank you so much.


#2

I followed this this KB article and it works


#3

Is there any solution for this problem ? Above link is not working.


#4

It’s silly that UiPath dropped the KB :frowning:

I am running robot from command line using following command:

cd %ProcessPath%
“c:\Program Files (x86)\UiPath\Studio\UiRobot.exe” -f “%ProcessPath%\Main.xaml” --monitor --rdp

Additionally I store robot’s credentials in Credential Manager (“UiPath:user=” must stay before the actual user name)
image

Robot’s service is running under local system

Hope it helps :slight_smile:
J0ska


#5

@J0ska Thanks for answer :slightly_smiling_face:

Firstly, I don’t have Orchestrator.
I tried your solution, but the problem is still.If I choose “whether user is logged on or not” on Windows Task Scheduler, The robot process does not work.(event viewer gives error : ACCESS DENIED).However, I choose “run only if user logged in” the robot still runs properly.

Actually, I don’t know which robot name to enter ? **UiPath:user=**name, what is the name of Robot ? is it computer name and my domain name, “like ABC\KL123”

Is it enough, Robot’s Credentials in Credential Manager ? Can I store the robot’s credentials in somewhere else?


#6

In your example the credential manager entry should name like UiPath:user=KL123
The Windows Scheduler Tasks should run under the same account, i.e. ABC\KL123 and with option “Run with highest privileges”

At least this works for me…

You may also want to check permissions to the folder %ProcessPath%. In 2018.2 there is a change - see " Security Project Considerations" in https://robot.uipath.com/v2018.2/docs/about-automation-projects-on-the-robot