Table Extraction Wizard


I am having an issue with the Table Extraction wizard. The web site I need to access requires logon, but I’ve found a public site which allows me to demonstrate the issue I’m seeing. If you follow these steps, you’ll see the issue:

  1. Browse to DataTables example - Form inputs. This includes a table as shown in the first screenshot below, where Name is a read-only label, but Age and Position are input textboxes, and Office is a selectable dropdown list
  2. Open the UiPath Table Extraction wizard, click Add Data, and then click on the first name field (“Airi Satou”). The table extraction wizard asks “would you like to extract all the columns from the table?”. Click Yes
  3. Click the “Preview Data” button. This shows a table as shown in the second screenshot below, where Name is displayed correctly, Age and Position are blank (which is my issue) and Office shows all the values (which doesn’t affect me, but which is nevertheless still wrong)

Please can somebody tell me how I can use the Table Extraction wizard with the above example to ensure I get values for the Age and Position columns - that should address my issue

Thanks in advance

welcome to the forum

have a first look here:

in addition to the provided url:

	<row exact="1">
		<webctrl tag="tr"/>
	<column exact="1" name="Column1" attr="text">
		<webctrl tag="tr"/>
		<webctrl tag="td" idx="1"/>
	<column exact="1" name="Column2" attr="value">
		<webctrl tag="tr"/>
		<webctrl tag="td" idx="2"/>
		<webctrl tag="input" idx="1"/>
	<column exact="1" name="Column3" attr="value">
		<webctrl tag="tr"/>
		<webctrl tag="td" idx="3"/>
		<webctrl tag="input" idx="1"/>
	<column exact="1" name="Column4" attr="value">
		<webctrl tag="tr"/>
		<webctrl tag="td" idx="4"/>
		<webctrl tag="select" />
		<webctrl tag="option" selected="selected" idx="1" />

we do see that the select is taking the first option but ignores the selected marker.

In this case we would recommend to check the result with the latest version of the UiPath.UiAutomation.Activites.

In case of the result is still not handling the selected option feel free to report it to UiPath via Bug/Feedback channel from Studio or here

Hi Peter. Many thanks for your response, which is really helpful. I can follow what you’re saying, but am new to UiPath and cannot find the “Edit Data Definition” button that you show in your screenshot. The preview window I’m seeing is in the screenshot of the original post and only has an “OK” button. Am I doing the right thing opening the Table Extraction wizard, and if so where do I find the “Edit Data Definition” button? Thanks again for your help

please do a screenshot of what you do see. We assume that the wizard within the modern design style is displayed. So we check for the alternate support steps. Thanks

Just give a try on completing the wizard and then edit manually the extract config on the properties of the activity

Hi Peter,

See below. This shows the web page being scraped, with the Extract Table Wizard and the Preview Results windows over the top

did update my answer from below. check the properties and edit afterwards

Cross Reference:

Thanks Peter. I’ve tried pasting your XML into the correct section, and then I get an error - I assume because the new XML only has tags but no tags? I’ll have a look tomorrow to try to work out the XML issue - at least I now know where to make those changes so am a step closer!

as you have seen, we communicated to Tech Team

this can happen, when the table settings and extract metadata are not matching within the configured columns

I’ve managed to clear the errors, but it’s still not working (in fact the output is identical to what I had originally, where the Name works, the Age and Position are blank, and the Office shows all options rather than the selected option).

I think my issue is that I don’t understand the XML metadata. When I run the Table Extraction wizard the generated XML metadata has the outer tags as , whereas in your XML you use “”. If I remove the tags I get errors, so I’ve taken the generated XML and your XML and have merged them together as below. This is now running, but still not delivering the correct results (see image below). I’ve pasted a picture below which shows the original and merged XML and results

Is there a page that explains the XML structure? Apologies, whilst I have a background in programming I don’t have in-depth experience with HTML/XML!

Thanks so much for your continued help

in general we configure the columns, get created also the table setting and afterwards we do reconfigure the extract metadata. when doing all manually we also have to take care about the matching table settings

Thanks. Is there a set of documentation on the XML Metadata tags? Changing the metadata is easy, but I have no idea what tags or values to enter! I feel like I’m so close to getting this working, but the XML you provided doesn’t work, and when I try to merge that XML with the original XML, that doesn’t work either. Thanks very much for your help

will have a look on it later and come back to you

as discussed above:

Extract Metadata

	<row exact='1'>
		<webctrl tag='tr' />
	<column exact='1' name='Column0' attr='text'>
		<webctrl tag='tr' />
		<webctrl tag='td' idx='1' />
	<column exact='1' name='Column1' attr='value'>
		<webctrl tag='tr' />
		<webctrl tag='td' idx='2' />
		<webctrl tag='input' idx='1' />
	<column exact='1' name='Column2' attr='value'>
		<webctrl tag='tr' />
		<webctrl tag='td' idx='3' />
		<webctrl tag='input' idx='1' />
	<column exact='1' name='Column3' attr='text'>
		<webctrl tag='tr' />
		<webctrl tag='td' idx='4' />
		<webctrl tag='select' idx='1' />
		<webctrl tag='option' selected='selected' idx='1' />

Table Settings:

SyntaxEditor Code Snippet

<Table xmlns:xsi='' xmlns:xsd='' Type='Structured'> <Column xsi:type='DataColumn' ReferenceName='Column0' Name='Name'> <Format xsi:type='TextColumnFormat' /> </Column> <Column xsi:type='DataColumn' ReferenceName='Column1' Name='Age'> <Format xsi:type='TextColumnFormat' /> </Column> <Column xsi:type='DataColumn' ReferenceName='Column2' Name='Position'> <Format xsi:type='TextColumnFormat' /> </Column> <Column xsi:type='DataColumn' ReferenceName='Column3' Name='Office'> <Format xsi:type='TextColumnFormat' /> </Column> </Table>


Done by following:

  • configuring all columns with the extraction wizard
  • post editing the extract metadata xml to the different attributes and the selected option element

Still we have the issue that the selected value is not extracted as already discussed above

Thanks so much for your continued help, but this doesn’t work for me. I just get the error below. I still don’t understand what XML tags I can use, but the clear difference to me is that the XML produced by the Table Extraction wizard is wrapped in “” tags whereas this new XML is wrapped in “” tags

please share your XAML file with us

Sequence.xaml (10.4 KB)

can you check?
Sequence_LJD.xaml (10.4 KB)

That new XAML file is working the first 3 columns! I haven’t yet checked the differences between the original file and the amended file, but will do later. The final column is not working, but I’m less worried as I don’t need to scrape a dropdown list. I will now continue with development and try to get to next level. Thanks so much for your help!