Warning msg by "test extraction" from "Extract table data" activity which triggers "extract wizard" when doing the extraction

I’m using “extract table data” activity for a webpage, and aftering defining the columns by using “extract wizard”, I also set “the next link”, but when I tried to do the “test extraction”, it popped up below msg. I did set “the next link” target and anchor(I put the setting screen shot below as well)

PS:my automation was executed without any warning, but no data was extracted to my set excel file.



I hope you are using the studiox version. So Extract table will be helpful to extract the Table data,
s o first you need to indicate the table to extract and then it will ask to indicate the enxt button to navigate to other pages for similar extraction.

Plz confirm whether you have completed the above steps. Also it will be better if you can share the screenshot of the page which you are trying to extract.

thanks for the reply, I confirmed the above steps you mentioned have already been done.
here is the screen shot I want to extract data from.


ok…So when you inspect on the table, is it selecting as a table and extracting the output? And while giving the navigation button(Next) alone you are getting this issue?

After selecting the table can you wait for some time and then provide the navigation button…

Also plz use table extraction and confirm you are not getting this issue for other tables. Maybe you can use rpachallenge.com and verify it once.

here is what happened to me.
when I use this site (https://rpachallengeocr.azurewebsites.net/ )to test, the “extract table data” activity goes well, and when I choose “no” to the question “would you like to extract all the columns from the table” in “Extract table” window, I can use “table extraction” to edit. everything goes well. I can also recur this by using my target website, and it goes well too.

however when I go back to my original automation, and do the same, the weird thing happened: after dragging into “extract table data” activity and clicking “Indicate target on screen”, it pops up a different window like below which is same as what i met originally. by using this “extract wizard” I can also do the column and “next” setting, but when do the test, it shows “target element must be set”, same as what I post originally. and I can’t find the right setting way of popping up “table extraction” window, but keep on getting “extract wizard” window. I think that’s the problem to the point.

PS: I compared my two automations: the success one which triggers the “table extraction” uses these two project dependencies:
the failed one which triggers the “extract wizard” uses different two project dependencies:
is version difference the root cause?

2022.5.7 : I tried to update the pkgs and make the failed one the same as the success one, then problem was solved, no “Extract Wizard” anymore.

Here can you press f12 and open the inspect window and check whether the Table is of tag . Because Table extraction will alllow either tables or pattern based extraction. Just cross check once.

if it’s to check my target website by using F12 to get the inspection window, i did, but I don’t know what to check. i don’t quite understand what you mean “whether the table is of tag”.

As i said in my last post, I can use “extract table data” activity in my target website correctly. I think that indicates the website itself has no problem. the problem is why my original automation always gives me “Extract Wizard” other than “Table Extraction”.

Maybe you can refer the below doc from uipath, which explains the Table extraction.

thanks Rahul, but it doesn’t help. this page had been studied before. it only shows “table extraction”, i already knew how to use it. I need to tackle with “Extract Wizard”. hope someone else can give us a hand here. thank you for your kind help so far!

:slightly_smiling_face: Here extract wizard is the first step which records the table format. But it is not Navigating from there. Is there any other reference pages which can use to check your issue. I hope you are using a confidential url.

problem solved by updating related pkgs. fyi.

Glad to hear that…:slightly_smiling_face:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.