Studio - Orchestrator - Robots

hello

i’m working on my assignment, and have ran into a series of provisioning related issues:

  1. In Studio: I have created a process, and published it
  2. In Orchestrator: I have created an environment and a single robot; I created a package and linked it to the environment.

Issues:
a. when running the process from Studio (open Excel, create a queue item for each XL row), I get the following error: Orchestrator information is not available. Please check if UiPath Robot Service is started.
b. I noticed that in Orchestrator: status of the robot is “Disconnected”

Questions:

  1. have I missed a provisioning step?
  2. do I need to “use” the Robot app from win tray?
    c. in the Robot app, status is “Robot unavailable”

Did you fill in the required information in the UIPath robot settings in the system tray ?

in Orchestrator, the status of the Robot is disconnected

in the Robot Settings, I copied the Machine Key but the status is also disconnected

If I may also ask about the credentials needed:

  • should I use the local machine’s credentials?
  • or the ones used to connect to the Orchestrator?

Local Machine

Hi

You have to use the same name of the local machine… and also the same credentials you use in your local machine… make sure you give the machine key as well… if those are done, it should be working?

Let know how it goes for you

1 Like

I have confirmed all the above, and still:

  • Robot status in orchestrator is “DISCONNECTED”
  • Robot service connected to the provisioned machine and status is “ROBOT UNAVAILABLE”

@nikosan can you check Robot running on Local machine using the same machine name. In your screenshot is different from Orchestrator Machine Name.

I hope Robot Provisioned in Orchestrator is from Different Machine.

You are absolutely right… that was it… thank you

If this solved your problem can you marked as Solved with Lahiru’s Answer

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.