Error Connecting to UiPath Orchestrator


I was creating a workflow using assets. I logged onto Orchestrator and did the following steps

  1. created a machine, extracted the machine code
  2. created an environment
  3. created a Robot , it shows the status as disconnected.
  4. Created an asset

back to the machine, I connected the Robot tray using the machine key, it now gives me an option to disconnect, but shows status below as “Robot Unavailable”

when i try to publish my workflow, it gives the error “Error: System.ApplicationException: Publish of workflow project to Orchestrator failed. A robot with user name ‘LANID’ is not defined in Orchestrator —> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: A robot with user name ‘LANID’ is not defined in Orchestrator”

where LANID is the name of my UserName on the local machine. I cleared everything and started from scratch but its just not working, what am i missing ?


@a2dhanja Check below thread.

Hey AD,

When you are connecting with the Orchestrator, make sure the machine name is the same as the machine name on which the Studio is installed. You can get that from the UiPath Agent window. Bot can be named as you like, but if machine name doesn’t match, the connectivity doesn’t happen.
Please find the screenshot attached below.


1 Like

Hi Nshrimali,

Thanks for the response, below is my snapshot



Are you sure the robot is running? Check for the icon in the tray, otherwise open the “Ui Robot” application :slight_smile:



Hi @a2dhanja

To solve the issue, please hover your mouse cursor over the test “Robot unavailable” and search this forum for the string that will be displayed.

It will surely land you the answer you need :slight_smile:

The snapshot posted by me was of the Robot Tray settings.
The issue was that the machine name in Orchestrator was different from the machine name shown in the Robo Tray settings,

Thanks for reaching out

Thanks @nshrimali

This indeed solved my problem. I was selecting a different name in Orchestrator. Setting the same name as shown in the Robot Tray settings solved the problem.

Cheers!!! :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.