Status of Robot in Orchestrator is still disconnected

Hello

My Uipath robot.exe is well connected to Orchestrator as shown in the screenshot below via correct Machine id:

image

I have added a robot whose status is disconnected. I have checked other responses in this forum for similar issue, and found that domain\username should be correctly id. I have already done that also, but still robot status is “disconnected”, check screenshot below:

Please suggest what should I do to resolve this issue ? Thanks

1 Like

Hello,

Your Orchestrator URL is not correct.
it should be in below format
http://platform.uipath.com/[AccountLogicalName]/[ServiceName]/

1 Like

Hi,

Although with the URL I have used was working fine till the time I have not updated community version. But I have tried based on your suggestion, below is the screenshot:

image

But even after this, the ROBOT status is still disconnected .

Please suggest.

Thanks

Check on orchestrator that the machine is in available state
Check the Machine key is matching with the one associated with your robot.
Use “Studio” type as Robot

1 Like

Hello,
Please clarify how to check machine is in available state, it shows connected and licenses in UiPath Robot.exe.

Machine key is perfectly matching.

I have change type as “Studio” but it did not worked.

Further analysis :
Please check below screenshot of the landing page on platform uipath, it shows there is 1 unattended license available:

Below is the screenshot of Machine (when I click Edit)

It shows zero unattended license. Is this the reason, can you help further ?

Regards

hi @ankswe,

Is your machine name the same as your computer name? You can check your computer name in Control Panel > System and Security > System.

Hello @ankswe,

I would just like to clarify some things.
First of, if the robot tray / Agent desktop is showing “Connected , Licensed” then your robot should indeed be connected and licensed.

Now, if the Orchestrator is showing a “Disconnected” status for that specific robot here are some things you can try:

  • Make sure that the robot that’s showing the “Disconnected” status is the same robot that has the “Connected, Licensed” status in the robot tray
  • Exit the settings page of your Robot tray.
  • Restart your robot service. You can do this via Task manager.

My guess is that there’s an issue with the robot agent (which is a component of UiRobot and is responsible for maintaining the robot connection to the Orchestrator) and a quick restart should fix this.

Now, regarding your other question about licensing.

Providing that you have indeed allocated an Unattended license to your tenant then:

  • It’s showing a license number of 0 in the Machine’s “License - Unattended Runtimes” because, as you mentioned you have set your robot license type to Studio
  • Notice that “Studio, Attended, StudioX” Licenses are not being shown there, that is because as of the latest Orchestrator update only Unattended, Testing, and Non-prod licenses can be executed via Orchestrator.
  • This license page of the Machine setting indicates the number of licenses used by the robots provisioned in that machine. Try chaging the license type of the robot provisioned to that machine to “Unattended” and you should see that the licenses in your Machine gets updated, specifically the “License - Unattended Runtimes”

Happy automating! :vulcan_salute:

Thanks for your detailed suggestions. Since even after the above suggestion it was not success. So, I deleted my robot and machine (from two different orchestrator/cloud rpa account where I was trying) and tried to build everything from scratch again. I was able to publish my process succesfully as shown in screenshot below.

Please check screenshots below, here there is no studio license, but based on ur suggestion I was able to select “Studio” in machine, but its status is “Available” i.e. it is not “Connected”.

License details in my orchestrator are shown below (i.e. one unattended is there):

So, I tried to change it to Unattended but I got below message, please suggest when it is already there and I am not using this license anywhere then why can’t I use it:

image

Below is the screenshot of UiRobot.exe

image

Can you suggest mechanism to resolve this issue, thanks again for spending time in reading this post .

Regards

@ankswe - pls follow below

1- Go to Platform.uipath.com --> Services and verify Unattended robot allocation - pls refer below link for https://docs.uipath.com/cloudplatform/docs/distributing-your-licenses

2- Go back to robot window screen ->Update Robot type as ‘Unattended’ and provide the password for the robot user in password textbox/field -> click on update

2 Likes

You will have to delete the UnAttended robot created previously. Then only you can use it

1 Like

Thanks dear, you made my day, after 2 days struggle this issue is resolved.

Regards
Ankit

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.