Strange things happening with unattended Automation

Hi all.

Ive published a process to orchestrator from an AWS EC2 instance. When I run the task from Orchestrator and have the server open on another screen the process runs fine. However, when I disconnect from the server and run the process I get a timeout error:


The process simply opens a browser, clicks a ‘Continue’ button, and logs in. It makes a few selections and logs out (so nothing very complex.

The timout seems to be occurring on the first ‘Continue’ click. Ive set the delay after to 8000 and the delay before to 60000… Any ideas on how to fix this?

Many thanks

HI @OrangeIstheWay

Check this in the machine in which the unattended process is running


Check robot type it should be as a service mode not a user mode

Besides the robot needing to be installed in service mode, as mentioned already, make sure people aren’t logging into the server with the robot account then just closing the RDP window. This leaves the session active and messes with UiPath. If someone logs in with a robot account (which they shouldn’t) then they must SIGN OUT completely.

It can be happening because the robot is unable to find the UiElement (‘continue’ button) at runtime. Try the following troubleshooting points

  1. Try using Simulate input mode
  2. Maximize browser window once the browser is opened.
  3. Ensure there is no popup from any other application on the screen.

HI All thanks so much for your advice… ive tried to reinstall UiPath on the VM but cant seem to see to option to set up as ‘service mode’… Is this available in Community Edition?

Many thanks,