ServiceNow Application Scope unable to configure

I am unable to connect to the ServiceNow Application scope using the connection window in UiPath Studio. On the first attempt, a window opens that displays “Missing redirect URL in application registration.” I am using OAuth 2.0 and the Endpoint Url is specified as “https://sbqa.service-now.com

1 Like

Hello @weston.oasen!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

I am having the same issue. I’ve verified with our ServiceNow admin that the OAuth setup has been completed exactly as described in the documentation. I am using secure credentials to store my user/password/ID/secret, retrieving and passing those into the ServiceNow Application Scope, and using the correct endpoint URL (“https://ourinstance.service-now.com/”).

Everything appears to be configured correctly, and the same credentials are able to connect successfully via Postman.

edit: I followed a tutorial on Youtube (UiPath And ServiceNow Integration - YouTube) and verified all of my configurations. The tutorial had the instance URL entered in the Redirect URL field on ServiceNow, which is not included in the official ServiceNow Setup documentation from UiPath; we made this change in ServiceNow and now we are receiving a browser window with error “Invalid redirect_uri” instead of the original “Missing redirect URL” error.

What is expected in this field? Is there a way to view the actual POST logs from the connection request to get more details on what is failing?

Hello:

I am using UiPath.Team service activity package (Christian), and having an issue to connect to ServiceNow

I am using a Test_dev mode of authentication, and using
consumer_Key
consumrer_secret
username
password
EndpointURL

I get this error back not sure, how to fix this

System.InvalidOperationException: An invalid request URI was provided. The request URI must either be an absolute URI or BaseAddress must be set.
at System.Net.Http.HttpClient.PrepareRequestMessage(HttpRequestMessage request)
at System.Net.Http.HttpClient.SendAsync(HttpRequestMessage request, HttpCompletionOption completionOption, CancellationToken cancellationToken)
at System.Net.Http.HttpClient.SendAsync(HttpRequestMessage request, CancellationToken cancellationToken)
at System.Net.Http.HttpClient.PostAsync(Uri requestUri, HttpContent content, CancellationToken cancellationToken)
at System.Net.Http.HttpClient.PostAsync(String requestUri, HttpContent content)
at UiPathTeam.ServiceNow.CmdRestAPI.d__63.MoveNext()

Thanks

I was able to fix it.
For some reason, if i define the values in variables didnt work. But if i assign the values directly, it did work.

Thanks

I was able to solve this issue with the ServiceNow Application Scope with some documentation from the ServiceNow developer portal - Create an endpoint for clients to access the instance

The Redirect URL must be configured in your ServiceNow Application Registry, and the URL must be the value that you will be connecting from. It must contain both the address and port, and In this case, I found a Listener IP address with a port in the error logs, and gave that a Google. I then found this listed as a requirement on some other OAuth/UiPath integrations -

For OAuth 2.0 you will need to add ( http://127.0.0.1:10001/authorize/ ) as the Redirect URIs (unless your company requires a different one).

That has solved the issue and I am now able to connect and use the ServiceNow integration without issue.