ServiceNow Application Scope Question

Hello, I am having issues setting up a connection to ServiceNow using the UiPath.Servicenow.Activities v1.2.0 package.

According to the documentation (ServiceNow Scope), which appears to be for a different version of the package than the latest version, all you need to do is setup the OAuth client in ServiceNow, then enter the credentials (User/Pass, Client ID/Secret) into the Scope activity to create a connection.

However, when I do this and try to test the connection, rather than getting the “Connection Successful” message shown in documentation, I get a popup browser window at the ServiceNow login page asking for my credentials, followed by a prompt to allow the Oauth client to interact as me:

I’ve verified this happens both on a fresh Developer instance, and on my company’s instance, so this doesn’t appear to be a instance-specific issue.

This isn’t the desired or described behavior; an integration user with the minimum-desired roles has been created, specified as an asset, and passed to the Connection Scope activity; however, that is seemingly discarded in favor of this login page which then gives the integration full access to everything that user has access to. I can enter some nonsense for the UserID/password in the credential asset (such as eggs/eggs1234) and this prompt will appear, the same as if I provide a valid User/Pass, suggesting that user Id and password are not actually being used for anything.

My only working theory is that it could have something to do with the redirect URL on the Ouath client in Servicenow? The setup documentation for the activity does not specify that anything should be entered there, but if left blank connecting gives a “missing redirect URI” error in a browser window, and pointing directly to the instance URL gives an “invalid redirect URI” error in a browser window; occasionally I would get an error about being unable to listen on 127.0.0.1:10001.

The only thing I’ve found that works at all was from the setup directions for a separate integration (Smartsheet Setup) that specifies that " or OAuth 2.0 you will need to add ( http://127.0.0.1:10001/authorize/ ) as the Redirect URIs." I set that as the redirect URL in ServiceNow, but now I am getting the login prompts described above.

If anyone has any further ideas on how to get this activity to connect using the provided User ID, without an additional manual login prompt, I would be very grateful for any assistance.

Hello @AaronTank!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff