Send SMTP Mail Message not working in some project

Hi! ,
This week I got issue about cannot receive email from
UiPath Studio Activities “Send SMTP Mail Message”

I’m not sure about reason.
Because my published project ran and sent email normally around 1 year ago until last Thursday.

I’ve checked my SMTP server running normally.
also email of sender and receiver can use normally.

Anyone have any idea.


I’ve created new project for test only this activity (Send SMTP Mail Message)

However, it cannot send email :smiling_face_with_tear:

Is there any migration happened in bot machine like 2012 to 2016 or 2019?

Thanks for your reply.

I’m not do anything after I published and ran my project on orchestrator. (previous year)
Now many jobs still running normally without error but I cannot receive email from Send SMTP activity.

:smiling_face_with_tear: :smiling_face_with_tear:

There are few reasons for this issue,

Mail size might be big (More than mentioned size in SMTP server Group).

Number of recipients per hour might exceeds ( in SMTP server Group).

Hope your bot is using static IP, if no then you need to add the IP address in SMTP server. Also check your SMTP server IP might be changed.

Above mentioned lines are just for clarity, you need to narrow down little more from SMPT Side. From UiPath end all you need to check the version which you are using in Studio, Assistant are compatibility with your Mail/SMTP service package)

  • Mail is small size (only text).
  • IP address of SMTP server not change.
  • I’m not sure about number of recipients per hour , but in previous month it’s still working normally.
  • My UiPath and SMTP can work together until 31 Mar 23.

My project include email loop 8 mails.
Yesterday bot sent only 7 mails.
Today bot cannot sent any mails.

Thanks. :smiling_face_with_tear: :smiling_face_with_tear:

Then there might be the reason of SSL or some sort of cert expired or got renewed.
Request you to reach your SMTP service team or who is managing certificate in your organization.

In case you are using your own SMTP server then pls check your SSL or SMTP server IIS cert (Local Cert) or if you using subscription model pls check the renewal

Hi @Hyde

Try restart the machine and re-installing the mail activities package.

Hi @Hyde

Check the email settings: Make sure that you have entered the correct email server settings, port number, email credentials, and recipient’s email address in the “Send SMTP Mail Message” activity. Double-check the email addresses to ensure there are no typos or other errors.

If it does not work then you try using a different email account or email server to test if the issue is specific to the email account or server you are currently using. If the issue persists, you may seek further assistance from the UiPath community or UiPath support team.

Thank u all,

I’ve tried all solutions but it cannot solve.

Now I need to change activity from Send SMTP Mail Message to Send Outlook Mail Message
also I must add outlook mail.

now it’s working.

However I will continue try to fix SMTP

Thanks again !!

:smiling_face_with_three_hearts: :smiling_face_with_three_hearts:

I’ve had the same symptoms as you for about a year. By any chance, is your email account Microsoft 365?

Yes , email of sender and receiver is O365.

Your issue already solved?


Maybe in your project the “Send SMTP Mail Message” activity is basic authentication (email account and password) like below?


Microsoft has been announcing the deprecation of the Basic authentication method for quite some time.
Basic Authentication and Exchange Online – February 2021 Update - Microsoft Community Hub

You should use OAuth to authenticate instead. However, for this, it is necessary to have an authentication key issued by the IT management department in Azure of Microsoft 365. It is similar to when using WEBAPI. In my organization, the IT department didn’t allow this, so I’m using the Outlook client to send emails, just like you are doing now. If your IT department understands your situation, you want to use OAuth, so please try to negotiate with them to issue an authentication key.

Good luck and Best Regards.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.