Send SMTP Mail Message No Longer Working, No Error

Hi -
I have multiple bots running on a remote server. As of December 28th they are no longer able to send any emails using the SMTP Mail Message activity.

No Error message is ever given, UIPath simply continues to “run” and never stops or times out, even though a timeout is coded in. No emails ever sent. No messages in the log.

  • Nothing has changed on any bot coding, all the credentials, messages are exactly the same
  • All Bots affected on the same remote server, none of them send emails
  • Email servers are up and running fine
  • I’m not able to use any other email activities as far as I know as the remote server does not have multiple email client software.
  • Using UIPath 2021.4.4, and initiating the bots manually as to watch, nothing has changed

I’ve tried the following:
Updated activity package to latest package
Downgraded activity package and tested, same result - no error
Changed the host port to 2525, 25, 587, all same result - no error
Added and removed timeout - always same result, no error
Changed the “SecureConnection” option and tried each option, same result, no error

Is there a known bug with a new windows update, or should I report this as a bug?
Anything else I can try?


Welcome to forums

You have enabled the IsBodyHTML, so is your body is as HTML Tags?

Check and let us know


Yes. I actually have one bot that does not have HTML tags, and the checkbox is unchecked - still, same result with no error given.

All bots have been running the same since October. No changes to the SMTP activity have been made.

Sounds like something changed with your SMTP server. Could be a DNS issue, authentication issue, relay has been disabled, certificate issue, could be a million things. You need an email admin to check their logs to see what is happening when your automation tries to send an email.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.