Send SMTP Mail Message not working anymore

Hi,
I use in all my robots an SMTP send mail function to send reports.
Since my upgrade to Studio 2021.10.3 it is not working anymore, with a message “Send SMTP Mail Message: Timed out while waiting for Mail Service to connect”
It is not config or network related, I can send an SMTP mail using PowerShell, it is clearly an UiPAth issue. Does anyone encountered that and has a solution please ?

Hi,

Could you please increase the time out to 60 seconds or more and try you are able to send email with send SMTP Mail Message activity.

eg: TimeoutMS - 60000

Hi,
It is the same…

@remy2283

Can you check if Firewall is activated and blocking? OR any Antivirus is blocking the request?

Also try to degrade / Upgrade the mail package

Hope this may help you

Thanks

Hello Srini84,
Like I said, I can send an SMTP mail with PowerShell, so it is not the antivirus or the firewall.
And yes, I tried degrading the mail package. It is the same.
Sometimes after a reboot it works again, but not for long…

Hey,
Maybe you will update version of package ‘UiPath.Mail.Activities’. For example Microsoft’s service ‘office365’ stopped using tls 1.1
Please update package to newest version and try again.
image

Hello Pikorpa,
I updated ‘UiPath.Mail.Activities’ to the latest v1.12.3 version when I updated Studio.
After the first SMTP errors I tried downgrading ‘UiPath.Mail.Activities’ to several versions, but it is the same…

@remy2283
Hi,
I am facing same error. Have you got any solution for this issue.

Hello Monika,
No solution with UiPath, I execute a PowerShell command to send my SMTP mails now.
I had to rewrite all my robots to bypass the native command that no longer works…