Selectors not working - Google Chrome

Hey @JayaTyagi, I was having similar issues a few weeks ago. It seems to have resolved itself (not sure what changed) but I did have success using the Open Application activity instead of the Browser activity.

I have all kinds of trouble with Chrome. UiPath seems to fail to either communicate with the browser, or find the first element after opening about 40% of the time. I just have to run it in a loop many times closing and re-opening the browser until I get lucky and it seems to catch. Very annoying, and I have no idea how to fix it.

Try this if you have local admin rights on your PC. Just un install your chrome and download latest version and install it.
if that also not working then try to check your DotNet Framework. That will definitely fix your issue.

My personal experience with Chrome has been rock solid on my dev machine. However… we just recently deployed our first ever “attended” robot on multiple users’ machines, and even though we generally followed the same installation & setup process… some machines are working well with Chrome, but others are non-starters because Chrome can’t find the very first element in my script. We can’t quite figure out what the difference is between the machines that work and the machines that don’t. In our case, though, it’s binary… it either works 100% or fails 100%.

Going to try removing & re-installing chrome and verifying the .NET version on the failing machines.

I solved this by adjusting the text display back to 100%
The screen selector is now working in Chrome
Hope this helps everyone else

@Gabriel_Tatu how this is even possible? :thinking:
selector and text display connection !

on win 10 if you have custom scaling, other than 100% - detection is broken, this is a known issue, it will be fixed in the next release


Hi @Gabriel_Tatu I am using windows 7. Can you tell me where you see it is a known issue? I would like to be included in that knowledge base for future issues.

The same issue has happened with my Chrome. The only thing I could do to fix it was to uninstall the Chrome extension and reinstall it.

That being said, the same thing happened while trying to select elements in a pdf file using Adobe Acrobat. My fix for that is found in this post.

These issues started happening after Windows performed an update and restarted my computer over night.

Dear @JayaTyagi . Did you find any solution for the issue.

@rkelchuri - I am using latest .NET framework. Do I need to downgrade?

  • Iam also facing a similar issue with chrome. Its able to identify individual fields but I am not able to access “Address Bar” of the chrome. Please find attached.

you have to open a “real” webpage in your tab in order to have detection of elements (not chrome store, not chrome tab)

Dear @gabriel - This I just put as a sample. I am facing issue for real webpage also. It was working before. Suddenly one day after windows update it stopped working.

Different Options i tried so far.

  • Reinstalled UI path
  • Reinstaled Chrome
  • Reinstalled UIpath plugin
  • Display size is 100%

Thanks a lot for you quick response.

Please check in your machine if you have DotNet 4.6.1 Multi-Targetting pack version or not

Can you tell us exactly what windows update broke it?

hi Gabriel,

it still won’t work for chrome.
It is strange that it was working when I just installed uipath and tried to record the screen using web. The selectors were working fine on Chrome, but after installing the chrome plugin, it doesn’t work. And i have tried all the above suggestions already, but no success

1 Like

Hi Pal,

What Studio version do you have? Also, did you try to remove the extension and install it again?

Maybe restart your computer? I have noticed that sometimes, even if you close Chrome window it doesn’t take the changes.


hi Viorela,

thanks for attending my request.
i tried everything but it work. still selects the whole chrome window as one element


In case of IFrame Chrome does not have access to it.
Everything else works for me but I cannot access the content of an IFrame. I always have to use Citrix / Click Image etc.
This is really annoying.
Thanks for solving this issue.

Sounds like this has been an open issue for over a year now without any resolution? @ClaytonM is that accurate? Just trying to sift through what I should try vs. what potential fixes are known to not work…

Hi @lukeb
Are you referring to an issue where the Chrome extension works until you restart the browser or something like that?

I have not been having any issues recently. I would suggest making sure you are on a newer version of Studio, like 2018 or newer. If you have not reinstalled your Chrome extension in a while, it may have gotten corrupted too, so you might just need to reinstall it (as to why this can occur, I am unsure)… Also, if you are using a Read-only Preferences file like I do to prevent setting changes, then you’ll need to uncheck Read-only on the Preferences file before reinstalling any extensions.

If you need more direct support, I would recommend using Technical Support: Contact Technical Support

Or PM me if you still can’t get your issue solved and we’ll figure it out.


1 Like