Selector not working on one part of an IE page

Hello all,

I am facing a strange issue. Some elements of a webpage cannot be identified with selectors. In some part of the page, no selection area appears and the selection stay located on the previous area selected… (see screenshot below, I am trying to identify elements on the right part with the mouse)

Moreover, I have tried Citrix automation in this part and it is like no image can be recognized. While doing the selection with the red arrow nothing is selected.

Can anyone help me with that ?

Thank you very much.


I have the following log when I try to use Citrix Click Text:

Step was not recorded successfully.

System.Exception: Step was not recorded successfully. —> UiPath.Core.ElementOperationException: Error HRESULT E_FAIL has been returned from a call to a COM component. —> System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.
at UiPath.UiNodeClass.Get(String bstrAttr)
at UiPath.Core.UiElement.Get(String attribute, Boolean refresh)
— End of inner exception stack trace —
at UiPath.Core.UiElement.Get(String attribute, Boolean refresh)
at UiPath.Core.UiElement.GetPosition()
at UiPath.Workflow.Wizards.ElementRecordingInfo.Init(UiElement element, UiElement topParent, Image image)
at UiPath.Workflow.Wizards.RecordingManager.InitRecordingStep(RecordingInfo recordingInfo, UiElement element, Image image)
at UiPath.Workflow.Wizards.RecordingManager.RecordStep(String wizAction)
at UiPath.Workflow.Wizards.RecordingManager.ProcessWizard(String action)
at UiPath.Workflow.ViewModels.WizardViewModel.OpenWizard(String action)
— End of inner exception stack trace —

Thank you,


Bonjour @QuentinPrevost
I assume you can’t share the website with us,
what I suggest is that you use UiExplorer and try to fine tune the selector until it fits, as of the Citrix Automation it’s not very recommended since you have to change the resolution and the image should not change so if you have different values inside the table shown in the screenshot it won’t work.
hope that helps :slight_smile:

Is that part of the IE page in a frame? As that will stop selectors from working usually.

@reda Indeed it is an internal portal of a client so I cannot share. The point is that as I cannot identify element on this part of the page, I am not able to get a selector (even if he is not working) so update in the UIExplorer cannot be considered at this stage.


@Alex_Cross, I haven’t seen any frame (it is an issue that I have already encountered) as you can see on the screen below.
What is strange is that the issue is not

  • I can select a large area but not a specific element in it (like with frame)
  • But is : there is an entire area that I cannot identify at all. Like if it was not existing

Do you have any idea ?

Thank you


In the highlighted window you can see the type is “mdw” which is a multi document window, and does appear to contain a frame (perhaps?) as you can see class=“mdwIFRAMECell” which makes me think it’s a frame within one of the windows. It could be that UiPath is simply not able to read into this section of the website as it can’t cope with mdw?

I have experienced today where it is unable to “see” the Windows Calendar from your task bar so this could be a similar issue.

You have tried also using “Select Image” and get the same issue I think you said, which makes me think UiPath might need an update for this? I could be wrong though, I will try and summon the mighty @loginerror or @nadim.warsi for their wisdom?


@Alex_Cross Indeed, I think we might have reach a current limit of UiPath so far. I will continue investigating on my side as well.

@Alex_Cross did you find new information on your side ?
Thank you,


I’ve not been able to make any progress here, sorry. I was hoping someone else with more knowledge would step in and help, as you can’t be the only one with this issue!

Hi @QuentinPrevost

It would be helpful if you could share the selector for the most detailed element you can pick?
Please share a screenshot from your UiExplorer with the entire tree and properties :slight_smile:

Hello @loginerror,

Please find below a screenshot highlighting the most detail element I can pick: it is the separation bar between the left part where selectors work and the right part (light blue) where I want to pick data and where selectors do not work.

A second screenshot with the UiExplorer interface. For information, I think that the light blue area corresponds to the “MDW” html tag.

Thank you for your help.


It indeed looks like there might be lack of support for this particular structure of your website.
Our team is investigating it further.

Would it be possible for you to provide at least a snapshot of the website (.mht file)? It would help a lot :slight_smile:
If you are not sure how to get there, it is a simple “Save As” .mht file.

Feel free to also share it via private message.

1 Like